*Fixed* Dead 4.3 vortec HELP - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old December 17th, 2012, 09:05 AM   #1
Jeep ZJ
Senior Member
 
Jeep ZJ's Avatar
 
Join Date: 12-27-09
Location: Grand Rapids, Mi
Posts: 2,246
iTrader: (17)
Mentioned: 0 Post(s)
Exclamation *Fixed* Dead 4.3 vortec HELP

1995 blazer 4.3 vortec. just turned 200k yesterday.

Long story short i was drive to a christmas party at the in laws and my blazer decided to just loose power. Out of no where RPMs went to 0 and the motor shut off.(i had this same problem with my ZJ and it was the fuel pump) PO said the fuel pump was replaced. i can hear it turn on so there is power. i just changed the plugs when i bought it(like 2 months ago). it turns over but after 2sec's of cranking it. then it makes a puff noise kinda like when an air compresser get full and blows off....

any help would be great. need to get it running asap. thanks

see post #9

Last edited by Jeep ZJ; December 17th, 2012 at 02:51 PM.
Jeep ZJ is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old December 17th, 2012, 09:28 AM   #2
tyzstuff
[ ]lllll[ ]
 
tyzstuff's Avatar
 
Join Date: 03-19-09
Location: Lansing/Michigan
Posts: 558
iTrader: (8)
Mentioned: 0 Post(s)
Default

I would start with the distributor cap.They are notorius for hairline cracking.Hell even damp air can make em all wacky.My Zr2 did the same thing.Couldn't even see the crack in it.Best of luck.
tyzstuff is offline   Reply With Quote
Old December 17th, 2012, 09:30 AM   #3
Jeep ZJ
Senior Member
 
Jeep ZJ's Avatar
 
Join Date: 12-27-09
Location: Grand Rapids, Mi
Posts: 2,246
iTrader: (17)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by tyzstuff View Post
I would start with the distributor cap.They are notorius for hairline cracking.Hell even damp air can make em all wacky.My Zr2 did the same thing.Couldn't even see the crack in it.Best of luck.
thanks thats what im thinking i will start with. its got the "flat" style distributor. it working on your ZR2??
Jeep ZJ is offline   Reply With Quote
Old December 17th, 2012, 09:46 AM   #4
tyzstuff
[ ]lllll[ ]
 
tyzstuff's Avatar
 
Join Date: 03-19-09
Location: Lansing/Michigan
Posts: 558
iTrader: (8)
Mentioned: 0 Post(s)
Default

I sold it last year.But yes it worked right off the get go.I had just replaced the plugs and within a week or two the cap took a crap.The guy that bought it still driving around.So I would say yes.Also my son had a blazer with the same setup and had similair problem and it was that cap as well.
tyzstuff is offline   Reply With Quote
Old December 17th, 2012, 09:55 AM   #5
Jeep ZJ
Senior Member
 
Jeep ZJ's Avatar
 
Join Date: 12-27-09
Location: Grand Rapids, Mi
Posts: 2,246
iTrader: (17)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by tyzstuff View Post
I sold it last year.But yes it worked right off the get go.I had just replaced the plugs and within a week or two the cap took a crap.The guy that bought it still driving around.So I would say yes.Also my son had a blazer with the same setup and had similair problem and it was that cap as well.
do you remeber if it had vert or horizontal towers?? W or Z motor??
Jeep ZJ is offline   Reply With Quote
Old December 17th, 2012, 09:57 AM   #6
tyzstuff
[ ]lllll[ ]
 
tyzstuff's Avatar
 
Join Date: 03-19-09
Location: Lansing/Michigan
Posts: 558
iTrader: (8)
Mentioned: 0 Post(s)
Default

They were horizontal.Right up tight to the trans dipstick tube.I dont remember on the w or z motor though.
tyzstuff is offline   Reply With Quote
Old December 17th, 2012, 10:00 AM   #7
Jeep ZJ
Senior Member
 
Jeep ZJ's Avatar
 
Join Date: 12-27-09
Location: Grand Rapids, Mi
Posts: 2,246
iTrader: (17)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by tyzstuff View Post
They were horizontal.Right up tight to the trans dipstick tube.I dont remember on the w or z motor though.
sweet. thats what im going to try first. mine is the W motor
Jeep ZJ is offline   Reply With Quote
Old December 17th, 2012, 10:42 AM   #8
beaterk5
Senior Member
 
beaterk5's Avatar
 
Join Date: 12-21-07
Location: dansville-48819
Posts: 1,082
iTrader: (3)
Mentioned: 0 Post(s)
Send a message via MSN to beaterk5
Default

Could also be improper fuel pressure, on the CPI vortecs just because you have pressure dosent mean its enough.
beaterk5 is offline   Reply With Quote
Old December 17th, 2012, 02:50 PM   #9
Jeep ZJ
Senior Member
 
Jeep ZJ's Avatar
 
Join Date: 12-27-09
Location: Grand Rapids, Mi
Posts: 2,246
iTrader: (17)
Mentioned: 0 Post(s)
Default

looks like it was just the rotor and cap looked bad too.

rotor screws fell out and where laying in the ditr. and the 2 alingment dowles where sheard right off. all fixed now. thanks for the help.
Jeep ZJ is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:36 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.14770 seconds with 49 queries