ford 390 heads question - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old October 19th, 2012, 04:20 PM   #1
bjkttr
Senior Member
 
bjkttr's Avatar
 
Join Date: 04-05-10
Location: Greenville MI
Posts: 847
iTrader: (10)
Mentioned: 0 Post(s)
Default ford 390 heads question

This is what I was told that my motor is that I got with a truck from the previous owner.

1. 390 .030 over flat top forged pistons
2. balanced crank and rods
3. 428 heads ported and polished intake and exhaust ports
4. ported intake to match the gaskets.
5. .512 lift 292 duration comp cam.
6. has a holly street avenger intake

was running a 750 cfm carb

now the head casting numbers are c6aer and the other one is c1ae and it also says 6090-a

My question is are these 428 heads how do I know and why are they different number?

One last question is that I though about selling the motor. It does need some gaskets replaced ( i have them just need installed) and could use some paint, how much would you ask? it ran when pulled ( ran really well) and thats about a year ago and has been stored inside.
bjkttr is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old October 19th, 2012, 04:51 PM   #2
cj65
Senior Member
 
cj65's Avatar
 
Join Date: 04-07-07
Location: 48174
Posts: 3,858
iTrader: (19)
Mentioned: 2 Post(s)
Default

Well they are most likely not 428 heads being one is a 1961 and ford didn't bulid the 428 then.
cj65 is offline   Reply With Quote
Old October 23rd, 2012, 09:58 AM   #3
chriszildjian17
Member
 
chriszildjian17's Avatar
 
Join Date: 08-13-11
Location: greenville,mi
Posts: 91
iTrader: (0)
Mentioned: 0 Post(s)
Default

here are the specs
http://www.mustangtek.com/heads/C1AE-6090-A.html
chriszildjian17 is offline   Reply With Quote
Old November 12th, 2012, 02:24 AM   #4
moparhorse
Senior Member
 
moparhorse's Avatar
 
Join Date: 10-31-12
Location: Beaverton
Posts: 675
iTrader: (4)
Mentioned: 0 Post(s)
Default

Who ever ported the heads dident do it the right way. Anytime you port a head, the LAST thing you do is polish the intake ports weather its the head or the intake. When that is done, you lose the factor of the fuel being vaporized before entering the combustion chambers. Which equals solid fuel droplets entering the chambers. To fix it is easy, just make the ports rough. The exhaust ports on the heads need to be polished as much as possible. Helps with airflow and spent exhaust gasses not making carbon stick to the ports, which also helps with scavenging. 390's are always cool!
moparhorse is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:35 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.11288 seconds with 32 queries