Help quick - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old June 17th, 2012, 03:25 AM   #1
twoodrow
The Rookie
 
twoodrow's Avatar
 
Join Date: 02-14-12
Location: Ionia MI
Posts: 13
iTrader: (0)
Mentioned: 0 Post(s)
Exclamation Help quick

my jeep starts but rpms fluctuate dropping to the point of almost stalling and then climbing to 3, 4k and does that rapidly. stalls after getting on the gas a few times, and when it does stall it sounds like its sucking air. its a 1998 jeep grand cherokee with a 318 5.2L v8.
Have replaced the timing gear and chain, plugs, wires, distributor cap, and the catalytic... What the H3#* else could it be??
twoodrow is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old June 17th, 2012, 05:32 AM   #2
RADRICK
Senior Member
 
RADRICK's Avatar
 
Join Date: 04-28-09
Location: Galien, Mi
Posts: 454
iTrader: (7)
Mentioned: 0 Post(s)
Default

could be caused by a vacuum leak, or possiblly a bad/ dirty IAC.
RADRICK is offline   Reply With Quote
Old June 17th, 2012, 05:47 AM   #3
Silver Bullet
Livin the American Dream
 
Silver Bullet's Avatar
 
Join Date: 04-18-07
Location: Westland, MI
Posts: 3,764
iTrader: (4)
Mentioned: 0 Post(s)
Default

Sucking noise? Sounds stupid but did you air box or tube come disconnected or get a hole in it after the mass air flow sensor.
Silver Bullet is offline   Reply With Quote
Old June 17th, 2012, 06:22 AM   #4
Jeeper52
Budget, what budget?
 
Jeeper52's Avatar
 
Join Date: 08-27-11
Location: windsor ontario
Posts: 680
iTrader: (4)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by radrick View Post
could be caused by a vacuum leak, or possiblly a bad/ dirty iac.
x2
Jeeper52 is offline   Reply With Quote
Old June 17th, 2012, 02:45 PM   #5
twoodrow
The Rookie
 
twoodrow's Avatar
 
Join Date: 02-14-12
Location: Ionia MI
Posts: 13
iTrader: (0)
Mentioned: 0 Post(s)
Default

Just acts like its not getting enough air, chugs stalls rpms jump shits just all over the place honestly
twoodrow is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:05 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.09446 seconds with 35 queries