95 pstroke is pissing my off!! need help - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old March 18th, 2012, 06:24 PM   #1
red87chevy
Senior Member
 
red87chevy's Avatar
 
Join Date: 09-14-09
Location: caro michigan
Posts: 678
iTrader: (1)
Mentioned: 0 Post(s)
Default 95 pstroke is pissing my off!! need help

I just bought this truck to be a tow rig
Its got 130k 2wd 5speed
I got 20 miles from were i bought it and it blows a fuel line some one put just reg no pressure 3/8 rubber line on there
Fixed that on the side of i96
Got it going made it 30 miles them check engine lifght white smoke and no power!
Replaced the egr presure swicth (cuz i broke it of with my knee changing lines)
Got it runnin again and ran ok took it down the road and the light came on again so
I changed the fuel filter and the tappit cover gasket and harness
Still doing it!! I live out in the middle of no where and i cant drive it to get it scanned
Any help would be nice
red87chevy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old March 18th, 2012, 06:30 PM   #2
Freak
Wheelin the HD
 
Freak's Avatar
 
Join Date: 01-27-07
Location: Portland, TX
Posts: 7,227
iTrader: (14)
Mentioned: 0 Post(s)
Send a message via MSN to Freak Send a message via Yahoo to Freak
Default

Sell it.
Freak is offline   Reply With Quote
Old March 18th, 2012, 06:35 PM   #3
red87chevy
Senior Member
 
red87chevy's Avatar
 
Join Date: 09-14-09
Location: caro michigan
Posts: 678
iTrader: (1)
Mentioned: 0 Post(s)
Default

Trust me im thinking about it!!
red87chevy is offline   Reply With Quote
Old March 18th, 2012, 06:54 PM   #4
kickstand
sHaMoNe!
 
kickstand's Avatar
 
Join Date: 09-20-06
Location: fenton
Posts: 31,757
iTrader: (46)
Mentioned: 37 Post(s)
Default

Quote:
Originally Posted by Freak View Post
Sell it.
helpful post is helpful
kickstand is offline   Reply With Quote
Old March 18th, 2012, 07:00 PM   #5
badazzchevy
go big or go home
 
badazzchevy's Avatar
 
Join Date: 10-02-08
Location: GRANDVILLE MI
Posts: 520
iTrader: (5)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by kickstand View Post
helpful post is helpful
So is spell check
badazzchevy is offline   Reply With Quote
Old March 18th, 2012, 07:16 PM   #6
red87chevy
Senior Member
 
red87chevy's Avatar
 
Join Date: 09-14-09
Location: caro michigan
Posts: 678
iTrader: (1)
Mentioned: 0 Post(s)
Default

Srry on my android buttons are to small!!
red87chevy is offline   Reply With Quote
Old March 18th, 2012, 09:41 PM   #7
Elvis13
Senior Member
 
Join Date: 05-15-11
Location: Addison Township, MI
Posts: 1,180
iTrader: (7)
Mentioned: 0 Post(s)
Default

So what is it still doing, white smoke and no power?
Elvis13 is offline   Reply With Quote
Old March 18th, 2012, 09:49 PM   #8
red87chevy
Senior Member
 
red87chevy's Avatar
 
Join Date: 09-14-09
Location: caro michigan
Posts: 678
iTrader: (1)
Mentioned: 0 Post(s)
Default

The smoke cleared up but it is running rough and no power then warms up and thros a ce light and then no power
red87chevy is offline   Reply With Quote
Old March 18th, 2012, 09:53 PM   #9
Elvis13
Senior Member
 
Join Date: 05-15-11
Location: Addison Township, MI
Posts: 1,180
iTrader: (7)
Mentioned: 0 Post(s)
Default

White smoke is usually unburnt fuel, on startup it usually means one or more of the glow plugs are not working, but the no power could be something else.

This will be really hard to diagnose via the internet without a scan. Do you think your turbo took a shit, or possibly that fuel line blew off something that would regulate/read boost?
Elvis13 is offline   Reply With Quote
Old March 18th, 2012, 10:12 PM   #10
special k
Senior Member
 
special k's Avatar
 
Join Date: 04-14-08
Location: South Lyon 48178
Posts: 3,090
iTrader: (38)
Mentioned: 0 Post(s)
Default

could be an IDM(injector driver module)
special k is offline   Reply With Quote
Old March 18th, 2012, 10:34 PM   #11
red87chevy
Senior Member
 
red87chevy's Avatar
 
Join Date: 09-14-09
Location: caro michigan
Posts: 678
iTrader: (1)
Mentioned: 0 Post(s)
Default

It has power till the check engine light comes on then no longer spools up
When i bought it it ran greAt now it doesnt once warm and sometimes idles rough...what is the fuel pressure sapose to be on the 95s?
red87chevy is offline   Reply With Quote
Old March 18th, 2012, 10:38 PM   #12
rreed101287
Member
 
Join Date: 05-15-11
Location: valparaiso/in
Posts: 64
iTrader: (0)
Mentioned: 0 Post(s)
Default

i have a 93 acted just like that it was the injection pump. the fuel line breaking probably caused the pump to take a shit
rreed101287 is offline   Reply With Quote
Old March 18th, 2012, 10:41 PM   #13
special k
Senior Member
 
special k's Avatar
 
Join Date: 04-14-08
Location: South Lyon 48178
Posts: 3,090
iTrader: (38)
Mentioned: 0 Post(s)
Default

95 isn't high pressure fuel, it's HEUI(Hydraulically actuated, Electronically controlled Unit Injector), so high pressure oil. could be a weak high pressure oil pump possibly
special k is offline   Reply With Quote
Old March 18th, 2012, 11:58 PM   #14
Elvis13
Senior Member
 
Join Date: 05-15-11
Location: Addison Township, MI
Posts: 1,180
iTrader: (7)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by special k View Post
95 isn't high pressure fuel, it's HEUI(Hydraulically actuated, Electronically controlled Unit Injector), so high pressure oil. could be a weak high pressure oil pump possibly
My 6.0 HEUI runs 50psi + for fuel.
Elvis13 is offline   Reply With Quote
Old March 19th, 2012, 11:51 AM   #15
red87chevy
Senior Member
 
red87chevy's Avatar
 
Join Date: 09-14-09
Location: caro michigan
Posts: 678
iTrader: (1)
Mentioned: 0 Post(s)
Default

Idk the gauge has it in the normal oil pressue in the gauge but i havent check fuel pressure yet im gonna after work hopefully what is it sapose to be?
red87chevy is offline   Reply With Quote
Old March 19th, 2012, 12:07 PM   #16
mudrunner78
Senior Member
 
mudrunner78's Avatar
 
Join Date: 04-15-10
Location: Memphis/ MI
Posts: 239
iTrader: (2)
Mentioned: 0 Post(s)
Default

What exactly did u break? Those engines dont have egr. 6.0L were the first in 2003. Did u break the icp sensor on accident?
mudrunner78 is offline   Reply With Quote
Old March 19th, 2012, 03:33 PM   #17
Elvis13
Senior Member
 
Join Date: 05-15-11
Location: Addison Township, MI
Posts: 1,180
iTrader: (7)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by red87chevy View Post
Idk the gauge has it in the normal oil pressue in the gauge but i havent check fuel pressure yet im gonna after work hopefully what is it sapose to be?
The stock oil pressure gauge is measuring low pressure oil created by your oil pump.

HEUI diesels have a gear driven HPOP that creates high pressure oil to fire your injectors. The ICP or IPR will monitor and regulate your high pressure oil.
Elvis13 is offline   Reply With Quote
Old March 19th, 2012, 11:12 PM   #18
red87chevy
Senior Member
 
red87chevy's Avatar
 
Join Date: 09-14-09
Location: caro michigan
Posts: 678
iTrader: (1)
Mentioned: 0 Post(s)
Default

No it was the egr pressure regulator i just bought on for a 95 pstroke and yes i kno that it but it is a indicator of low pressure from the hpop
red87chevy is offline   Reply With Quote
Old March 20th, 2012, 10:59 AM   #19
red87chevy
Senior Member
 
red87chevy's Avatar
 
Join Date: 09-14-09
Location: caro michigan
Posts: 678
iTrader: (1)
Mentioned: 0 Post(s)
Default

Bump
red87chevy is offline   Reply With Quote
Old March 20th, 2012, 01:17 PM   #20
Elvis13
Senior Member
 
Join Date: 05-15-11
Location: Addison Township, MI
Posts: 1,180
iTrader: (7)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by red87chevy View Post
No it was the egr pressure regulator i just bought on for a 95 pstroke and yes i kno that it but it is a indicator of low pressure from the hpop
HUH? Egr pressure regulator? What are you saying?

My guess is that you replaced the IPR.

Why did you type bump? is it fixed?
Elvis13 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:26 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.27399 seconds with 82 queries