help - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old March 10th, 2012, 01:09 PM   #1
madeforspeed
Newbie
 
madeforspeed's Avatar
 
Join Date: 01-06-11
Location: angola IN
Posts: 21
iTrader: (1)
Mentioned: 0 Post(s)
Default help

i just replaced my 2.9 in my 87 ranger because it had a rod knock and i got new moter in and there is no fuel to the rale but you can hear the pumps kick on and there is almost half tank in the truck what could it be
madeforspeed is offline   Reply With Quote
Old March 10th, 2012, 03:41 PM   #2
Captain Ledd
Ranger Addiction?
 
Captain Ledd's Avatar
 
Join Date: 11-06-05
Location: Davisburg
Posts: 2,065
iTrader: (31)
Mentioned: 0 Post(s)
Default

most likely a kinked line if there's suddenly no fuel.

Is it not firing the injectors? or is there truely no fuel getting to the line? (you bled the fuel rail with the tire valve looking thing right?)
Captain Ledd is offline   Reply With Quote
Old March 14th, 2012, 08:47 PM   #3
madeforspeed
Newbie
 
madeforspeed's Avatar
 
Join Date: 01-06-11
Location: angola IN
Posts: 21
iTrader: (1)
Mentioned: 0 Post(s)
Default fuel

i not getting gas to rail at all but pumps kick in would it be the fuel pressher regulator
madeforspeed is offline   Reply With Quote
Old March 14th, 2012, 08:51 PM   #4
GREASYHANDS
arachnis deathacis
 
GREASYHANDS's Avatar
 
Join Date: 03-16-09
Location: Ravenna
Posts: 12,991
iTrader: (28)
Mentioned: 20 Post(s)
Default

Are you sure your injectors are firing?
__________________
Bare Bones Offroad
RIP FS4L
Pavement sucks
Meow
GREASYHANDS is offline   Reply With Quote
Old March 14th, 2012, 11:11 PM   #5
Captain Ledd
Ranger Addiction?
 
Captain Ledd's Avatar
 
Join Date: 11-06-05
Location: Davisburg
Posts: 2,065
iTrader: (31)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by madeforspeed View Post
i not getting gas to rail at all but pumps kick in would it be the fuel pressher regulator
Quote:
Originally Posted by GREASYHANDS View Post
Are you sure your injectors are firing?
If no gas squirted out of that bleeder valve and you're positive the pump is turning on and pumping, you have either a blocked line, or a kink in the line. Most likely a kink or somewhere accidentally got crushed shut.

You can rent injector test lights at Autozone. They plug into the fuel injector connector and has a little light that will flash when the injector gets the electrical signal to fire.

Seriously, go over your fuel lines from the rail to the tank.
Captain Ledd is offline   Reply With Quote
Old March 15th, 2012, 12:24 PM   #6
madeforspeed
Newbie
 
madeforspeed's Avatar
 
Join Date: 01-06-11
Location: angola IN
Posts: 21
iTrader: (1)
Mentioned: 0 Post(s)
Default fuel

i pulled of line at rail and it shoots gas but none to rail
madeforspeed is offline   Reply With Quote
Old March 15th, 2012, 12:31 PM   #7
Bones
skillicous
 
Bones's Avatar
 
Join Date: 11-06-05
Location: Dearborn Heights, MI
Posts: 11,451
iTrader: (37)
Mentioned: 2 Post(s)
Send a message via AIM to Bones
Default

Quote:
Originally Posted by madeforspeed View Post
i pulled of line at rail and it shoots gas but none to rail
your sentance makes no logical sense. Please try again.
__________________
Inviscid Motorsports

Special Thanks and Recommendations to;
Motorcity Machines
Ironman Offroad
Branik Motorsports
Maxxis Tires

Raceline Wheels
PAC Racing Springs
Joint Clutch and Gear
Bones is offline   Reply With Quote
Old March 15th, 2012, 01:11 PM   #8
kevinr839
Senior Member
 
kevinr839's Avatar
 
Join Date: 03-19-06
Location: petersburg, MI
Posts: 840
iTrader: (3)
Mentioned: 0 Post(s)
Default

Sounds like the injectors are not firing. Did you try removing an injector from the rail and see if fuel comes out there? If no fuel comes out i would think regulator. If fuel comes out i would look for a missed ground or something.
kevinr839 is offline   Reply With Quote
Old March 17th, 2012, 12:11 AM   #9
madeforspeed
Newbie
 
madeforspeed's Avatar
 
Join Date: 01-06-11
Location: angola IN
Posts: 21
iTrader: (1)
Mentioned: 0 Post(s)
Default ..

the line that goes in the fuel presser regulator when i pull it of it shoots out gas but don't push it though the regulator and in to rail and i replaced the regulator what could it be and if any one can get me a vacuum diagram for a 87 ranger 29v6 would be great thanks.
madeforspeed is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:52 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.17450 seconds with 49 queries