Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Suzuki Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old February 8th, 2012, 05:54 PM   #1
mudslinger183
Senior Member
 
mudslinger183's Avatar
 
Join Date: 09-19-09
Location: Muskegon Mi
Posts: 322
iTrader: (0)
Mentioned: 0 Post(s)
Default 1990 geo tracker issues Wont Start

i have a 90 tracker with the 1.6l auto. it is rollin over but wont start. has spark, but smells flooded out.. im not too familiar with these trackers but was hopin for input.. please help if u can.. thanks
mudslinger183 is online now   Reply With Quote
Old February 8th, 2012, 06:12 PM   #2
93trackaddict
Senior Member
 
93trackaddict's Avatar
 
Join Date: 08-14-08
Location: quincy michigan
Posts: 518
iTrader: (4)
Mentioned: 0 Post(s)
Default

Timing belt?
93trackaddict is offline   Reply With Quote
Old February 8th, 2012, 06:19 PM   #3
mudslinger183
Senior Member
 
mudslinger183's Avatar
 
Join Date: 09-19-09
Location: Muskegon Mi
Posts: 322
iTrader: (0)
Mentioned: 0 Post(s)
Default

thats what i was thinkin just because i was drivin it one day and it just died all of a sudden.. so i think i might try that unless anyone knows different
mudslinger183 is online now   Reply With Quote
Old February 8th, 2012, 09:43 PM   #4
scottie
American Leyland??
 
scottie's Avatar
 
Join Date: 11-05-05
Location: Sweet home Georgia on my mind
Posts: 8,488
iTrader: (2)
Mentioned: 1 Post(s)
Send a message via AIM to scottie
Default

check timing belt, but if you have spark at the spark plugs then it's probably not broken. I guess it could have jumped some teeth. I'd start there.

Other than that, i'd start check the basics, fuel, electrics, etc
scottie is offline   Reply With Quote
Old February 9th, 2012, 11:16 AM   #5
mudslinger183
Senior Member
 
mudslinger183's Avatar
 
Join Date: 09-19-09
Location: Muskegon Mi
Posts: 322
iTrader: (0)
Mentioned: 0 Post(s)
Default

ok will start with that.. and its not broken so im guessin it just jumped some teeth.. i dont know what it would be in the electrical because like i said it has spark just no start lol..
mudslinger183 is online now   Reply With Quote
Old February 9th, 2012, 03:58 PM   #6
karl214
Senior Member
 
Join Date: 01-26-07
Location: Cadillac area
Posts: 115
iTrader: (0)
Mentioned: 0 Post(s)
Default

Could also be the ECM

Last edited by karl214; February 9th, 2012 at 07:33 PM.
karl214 is offline   Reply With Quote
Old February 9th, 2012, 04:31 PM   #7
bee
Senior Member
 
bee's Avatar
 
Join Date: 10-26-09
Location: Walker
Posts: 277
iTrader: (0)
Mentioned: 1 Post(s)
Default Tracker Issues

Another cheap (but often overlooked) item to replace is the fuel filter. I had a rusty gas tank in mine and it caused all kinds of issues from no start to bogging etc. Mine also had a new timing belt, but it was installed one tooth off. The tracker ran, but not very good.
bee is offline   Reply With Quote
Old February 10th, 2012, 12:34 AM   #8
mudslinger183
Senior Member
 
mudslinger183's Avatar
 
Join Date: 09-19-09
Location: Muskegon Mi
Posts: 322
iTrader: (0)
Mentioned: 0 Post(s)
Default

yea im gonna try timing belt this weekened on it and hope that fixes it lol..
mudslinger183 is online now   Reply With Quote
Old February 12th, 2012, 01:39 PM   #9
fruzz
we todd did
 
fruzz's Avatar
 
Join Date: 08-31-07
Location: spring lake
Posts: 138
iTrader: (1)
Mentioned: 0 Post(s)
Default no

my 92 did the same thing and it was the hot wire from the computer got fried. the computer gets corroded if its is subjected to a lot of moister. if it jumped time i think you would have bigger problems then it not starting
fruzz is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Suzuki Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:23 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.13306 seconds with 30 queries