03 Avalanche - Starts then stalls immediatly - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old December 30th, 2011, 12:29 PM   #1
MT-Dawg
Camel Buggy
 
MT-Dawg's Avatar
 
Join Date: 04-02-07
Location: F-L-I-N-T South Side
Posts: 735
iTrader: (6)
Mentioned: 0 Post(s)
Default 03 Avalanche - Starts then stalls immediatly

2003 Z71 Chevy Avalanche. I can start the truck, then it runs for a second or two normally and either sputters and shuts off, or shuts off immediately. I changed the fuel filter but it didn't help. No check engine lights come on.

I cleaned the air filter, cleaned the intake with a gumout and a toothbrush. checked for spark - good.

I turn the key forward and can hear the fuel pump kick on for a brief second. Any ideas???
__________________
"Opportunity knocks once" Not true... In some cases it never comes knocking, you have to go out and grab it by the hippie pony tail, and drag it over to your place for wine and chocolate."
MT-Dawg is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old December 30th, 2011, 01:16 PM   #2
jeepitupyo
MMM Shrimp Slushy
 
jeepitupyo's Avatar
 
Join Date: 01-23-06
Location: Flint 48507
Posts: 1,977
iTrader: (24)
Mentioned: 0 Post(s)
Send a message via AIM to jeepitupyo
Default

Theft system?
__________________
05 Silverado Crew Z71
00 XJ BDS Long Arms 35's
Beelby & Sons Towing
St. Pierre Inc. Machining and Welding
jeepitupyo is offline   Reply With Quote
Old December 30th, 2011, 01:20 PM   #3
chadcooper55
expert jeep disassembler
 
chadcooper55's Avatar
 
Join Date: 08-28-08
Location: kent city mi
Posts: 8,025
iTrader: (20)
Mentioned: 10 Post(s)
Default

Key switch?
chadcooper55 is offline   Reply With Quote
Old December 30th, 2011, 02:02 PM   #4
MT-Dawg
Camel Buggy
 
MT-Dawg's Avatar
 
Join Date: 04-02-07
Location: F-L-I-N-T South Side
Posts: 735
iTrader: (6)
Mentioned: 0 Post(s)
Default

The light does not come on for the theft system. I turned the key forward and waited to see if the theft system "lock" light came on....nothing. Is hit the lock / unlock button to try to reset the theft system, but that didn't work. I didn't think it would start if the theft system was active. I'm still baffled?
__________________
"Opportunity knocks once" Not true... In some cases it never comes knocking, you have to go out and grab it by the hippie pony tail, and drag it over to your place for wine and chocolate."
MT-Dawg is offline   Reply With Quote
Old December 30th, 2011, 02:14 PM   #5
IFS SUCKS
I like trees
 
IFS SUCKS's Avatar
 
Join Date: 09-20-07
Location: Lansing,MI
Posts: 5,796
iTrader: (6)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by MT-Dawg View Post
The light does not come on for the theft system. I turned the key forward and waited to see if the theft system "lock" light came on....nothing. Is hit the lock / unlock button to try to reset the theft system, but that didn't work. I didn't think it would start if the theft system was active. I'm still baffled?

30 Minute Learn Procedure





1.

Turn ON the ignition, with the engine OFF.





2.

Attempt to start the engine, then release the key to ON; the vehicle will not start.





3.

Observe the SECURITY telltale; after approximately 10 minutes the telltale will turn OFF.





4.

Turn OFF the ignition, and wait 5 seconds.





5.

Repeat steps 1 through 4 two more times for a total of 3 cycles/30 minutes; the vehicle is now ready to relearn the Passlock Sensor Data Code and/or passwords on the next ignition switch transition from OFF to CRANK.







Important: The vehicle learns the Passlock Sensor Data Code and/or password on the next ignition switch transition from OFF to CRANK. You must turn the ignition OFF before attempting to start the vehicle.





6.

Start the engine. The vehicle has now learned the Passlock Sensor Data Code and/or password.





7.

With a scan tool, clear any DTCs, if needed. History DTCs will self clear after 100 ignition cycles.
IFS SUCKS is offline   Reply With Quote
Old December 31st, 2011, 10:42 AM   #6
Kodiak450r
Keep on truckin
 
Kodiak450r's Avatar
 
Join Date: 11-14-07
Location: Waterford, MI
Posts: 5,911
iTrader: (19)
Mentioned: 0 Post(s)
Default

crank sensor wires intact? i dealt with this awhile back on a intrigue. sensor wiring was fucked up and caused the pcm to think the engine was running at 1680000 rpm. moved the wires around and problem fixed.
Kodiak450r is offline   Reply With Quote
Old December 31st, 2011, 10:58 AM   #7
bigbchevy
missmrgreenagain
 
bigbchevy's Avatar
 
Join Date: 09-15-07
Location: fenton /hartland mi
Posts: 18,742
iTrader: (167)
Mentioned: 42 Post(s)
Default

Quote:
Originally Posted by Kodiak450r View Post
crank sensor wires intact? i dealt with this awhile back on a intrigue. sensor wiring was fucked up and caused the pcm to think the engine was running at 1680000 rpm. moved the wires around and problem fixed.
almost 2mill rpm
__________________
H.o.r.e
(mr.green)So you are calling CC a liar?? Not a nice way to treat your bitch.
tube bending and gear installs pm me for info! gears installed for $150 and up per axle.
bigbchevy is offline   Reply With Quote
Old December 31st, 2011, 11:00 AM   #8
Kodiak450r
Keep on truckin
 
Kodiak450r's Avatar
 
Join Date: 11-14-07
Location: Waterford, MI
Posts: 5,911
iTrader: (19)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by bigbchevy View Post
almost 2mill rpm
thats what the scan tool said. bizarre right lol
Kodiak450r is offline   Reply With Quote
Old December 31st, 2011, 11:09 AM   #9
mjvan44
GIT UP ON HER AN RIDE!!!
 
mjvan44's Avatar
 
Join Date: 02-01-09
Location: white lake
Posts: 161
iTrader: (1)
Mentioned: 0 Post(s)
Default

Flick the door locks back and forth. I had the same issue and the theft system went haywire. Happened to mess with locks and it started right up. good luck......
mjvan44 is offline   Reply With Quote
Old December 31st, 2011, 11:10 AM   #10
buttercr125
I work out
 
buttercr125's Avatar
 
Join Date: 02-10-09
Location: Fenton, mi
Posts: 2,555
iTrader: (26)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by Kodiak450r View Post
thats what the scan tool said. bizarre right lol
True story...I went and looked at it for him. When I hooked the scanner to it and cranked it over the rpm's would go from 0 and not registering anything to a crazy number. The wires going to the crank senor where soaked in oil and shoring out. Moved the wires a little bit to separate them and it started reading fine. They wires still needed to be repaired though.
__________________
If your thinking about dealing with JoshuaCripe read the link below first!!
http://www.greatlakes4x4.com/showthread.php?t=219276
buttercr125 is offline   Reply With Quote
Old December 31st, 2011, 11:11 AM   #11
buttercr125
I work out
 
buttercr125's Avatar
 
Join Date: 02-10-09
Location: Fenton, mi
Posts: 2,555
iTrader: (26)
Mentioned: 0 Post(s)
Default

Do you have a check engine light coming on with the key on and engine off? If not you have a PCM issue more than likely.
__________________
If your thinking about dealing with JoshuaCripe read the link below first!!
http://www.greatlakes4x4.com/showthread.php?t=219276
buttercr125 is offline   Reply With Quote
Old December 31st, 2011, 05:42 PM   #12
firehawk
Live Action!
 
firehawk's Avatar
 
Join Date: 10-02-07
Location: Clawson, Michigan
Posts: 12,404
iTrader: (44)
Mentioned: 6 Post(s)
Default

Did you check the fuel pressure?
firehawk is offline   Reply With Quote
Old December 31st, 2011, 05:46 PM   #13
unluckyal
i like to party
 
unluckyal's Avatar
 
Join Date: 03-13-06
Location: waterford
Posts: 580
iTrader: (9)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by firehawk View Post
Did you check the fuel pressure?
x2... check fuel pressure should be between 50 and 60 psi on the rail. common problem even though the truck starts for a second the pump gets hot and turns off.
unluckyal is offline   Reply With Quote
Old December 31st, 2011, 05:55 PM   #14
Rob the plumber
Licensed master plumber
 
Rob the plumber's Avatar
 
Join Date: 06-14-06
Location: New Baltimore, Michigan
Posts: 5,638
iTrader: (32)
Mentioned: 1 Post(s)
Default

Sounds like an alarm issue
Rob the plumber is offline   Reply With Quote
Old January 1st, 2012, 09:27 PM   #15
MT-Dawg
Camel Buggy
 
MT-Dawg's Avatar
 
Join Date: 04-02-07
Location: F-L-I-N-T South Side
Posts: 735
iTrader: (6)
Mentioned: 0 Post(s)
Default

The fuel pressure was almost nothing. I am changing the fuel pump. Thanks for everyone's input. I should have the new fuel pump in tomorrow (Monday 1/2)...so I believe this should fix it.
__________________
"Opportunity knocks once" Not true... In some cases it never comes knocking, you have to go out and grab it by the hippie pony tail, and drag it over to your place for wine and chocolate."
MT-Dawg is offline   Reply With Quote
Old January 1st, 2012, 09:40 PM   #16
Freak
Wheelin the HD
 
Freak's Avatar
 
Join Date: 01-27-07
Location: Portland, TX
Posts: 7,227
iTrader: (14)
Mentioned: 0 Post(s)
Send a message via MSN to Freak Send a message via Yahoo to Freak
Default

My 01 would do this every so often, if I locked and unlocked the doors it would start just fine.
__________________
Motors hate me, axles fear me.

I got your jeep thing, now my damn Chevy wont start, and its missing a wheel.
My build: http://www.greatlakes4x4.com/showthread.php?t=206107
Freak is offline   Reply With Quote
Old January 2nd, 2012, 10:19 AM   #17
MT-Dawg
Camel Buggy
 
MT-Dawg's Avatar
 
Join Date: 04-02-07
Location: F-L-I-N-T South Side
Posts: 735
iTrader: (6)
Mentioned: 0 Post(s)
Default

New fuel pump installed and its running!

If I would have borrowed or rented a gage to check fuel pressure, I may have diagnosed earlier. But I did not have the proper tools initially. I figured when I heard the fuel pump turn on and gas squirted out when I cracked the fuel line at the fuel filter that the fuel pump was working....I learned the hard way.

Thanks to everyone for all your suggestions. The security reset info will come in handy in the future.
__________________
"Opportunity knocks once" Not true... In some cases it never comes knocking, you have to go out and grab it by the hippie pony tail, and drag it over to your place for wine and chocolate."
MT-Dawg is offline   Reply With Quote
Old January 2nd, 2012, 10:22 AM   #18
Rob the plumber
Licensed master plumber
 
Rob the plumber's Avatar
 
Join Date: 06-14-06
Location: New Baltimore, Michigan
Posts: 5,638
iTrader: (32)
Mentioned: 1 Post(s)
Default

Good to hear.
Rob the plumber is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:02 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.28848 seconds with 74 queries