v10 f150 - Page 3 - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Rig Builds and Pics
GL4x4 Live! GL4x4 Casino

Rig Builds and Pics Introduce your rig or post a buildup here.

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old January 28th, 2013, 06:36 PM   #41
sbcrichie
R&R Fabwerks
 
sbcrichie's Avatar
 
Join Date: 08-30-09
Location: sturgis/michigan
Posts: 1,206
iTrader: (8)
Mentioned: 2 Post(s)
Default

thanks
sbcrichie is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old January 28th, 2013, 06:55 PM   #42
sbcrichie
R&R Fabwerks
 
sbcrichie's Avatar
 
Join Date: 08-30-09
Location: sturgis/michigan
Posts: 1,206
iTrader: (8)
Mentioned: 2 Post(s)
Default







sbcrichie is offline   Reply With Quote
Old February 1st, 2013, 07:50 PM   #43
sbcrichie
R&R Fabwerks
 
sbcrichie's Avatar
 
Join Date: 08-30-09
Location: sturgis/michigan
Posts: 1,206
iTrader: (8)
Mentioned: 2 Post(s)
Default

built a air box today, gonna build a steering fluid resivior to that will hang off the side of the air box.









sbcrichie is offline   Reply With Quote
Old February 1st, 2013, 08:59 PM   #44
IDIeselman
Senior Member
 
IDIeselman's Avatar
 
Join Date: 03-23-07
Location: ludington mi
Posts: 1,848
iTrader: (18)
Mentioned: 0 Post(s)
Default

YOU pilgrim do great work, the attention to detail is impressive. When does the conversion kit come to market?
IDIeselman is offline   Reply With Quote
Old February 1st, 2013, 09:05 PM   #45
sbcrichie
R&R Fabwerks
 
sbcrichie's Avatar
 
Join Date: 08-30-09
Location: sturgis/michigan
Posts: 1,206
iTrader: (8)
Mentioned: 2 Post(s)
Default

thanks. i dont think there is a big enough market for this conversion to put together a kit.
sbcrichie is offline   Reply With Quote
Old February 1st, 2013, 09:21 PM   #46
jaysusr
Senior Member
 
jaysusr's Avatar
 
Join Date: 03-29-10
Location: Oakland county.
Posts: 1,055
iTrader: (2)
Mentioned: 0 Post(s)
Default

This is truly impressive. It makes my head hurt to imagine pinning all that electronics out and figuring out how to make it work. With these kinda skills I'd guess you were a deiveability guy in a former life.
jaysusr is offline   Reply With Quote
Old February 1st, 2013, 09:28 PM   #47
sbcrichie
R&R Fabwerks
 
sbcrichie's Avatar
 
Join Date: 08-30-09
Location: sturgis/michigan
Posts: 1,206
iTrader: (8)
Mentioned: 2 Post(s)
Default

No I actually haven't had much experience with newer computer stuff, I didn't have a choice but too figure this out because I told the customer I could do it before I really understood what all was involved. I honestly thought I would have place like Howell build me a custom harness, then when I started calling around I found out no body does ford wiring.
sbcrichie is offline   Reply With Quote
Old February 2nd, 2013, 09:45 PM   #48
tator
Senior Member
 
tator's Avatar
 
Join Date: 09-19-07
Location: sturgis
Posts: 529
iTrader: (7)
Mentioned: 0 Post(s)
Default

You still have it in your shop I'd like to come take a look at it.
tator is offline   Reply With Quote
Old February 3rd, 2013, 07:17 AM   #49
sbcrichie
R&R Fabwerks
 
sbcrichie's Avatar
 
Join Date: 08-30-09
Location: sturgis/michigan
Posts: 1,206
iTrader: (8)
Mentioned: 2 Post(s)
Default

yea its at shop still
sbcrichie is offline   Reply With Quote
Old February 19th, 2013, 08:02 PM   #50
sbcrichie
R&R Fabwerks
 
sbcrichie's Avatar
 
Join Date: 08-30-09
Location: sturgis/michigan
Posts: 1,206
iTrader: (8)
Mentioned: 2 Post(s)
Default

well got everything pretty much wrapped up but motor wont run. after some trouble shooting think i have it figured out. the old motor was a 99 so i have 99 computer in the truck well after switching to new 2003 motor truck just sputters a little and dies and gets a cam sensor code and crank sensor code so i called the ford dealer and asked if they changed the reluctor ring between the two years and he said they have different part numbers, wish i hadnt turned in the old motor for core yet the dealer is trying to get me a new ring for a 99 but its taking forever.











sbcrichie is offline   Reply With Quote
Old February 22nd, 2013, 12:44 PM   #51
twelve
Senior Member
 
twelve's Avatar
 
Join Date: 10-09-09
Location: Ponticrack
Posts: 411
iTrader: (0)
Mentioned: 0 Post(s)
Default

Did you take care of the weak plug threads before you put it in or are they good. I ask because i just changed a 5.4 in an expedition and i went ahead and pulled the heads and had the plug threads done before anything happened. I've heared V-10's have the same problem and it's cheaper and easier with the heads off.
twelve is offline   Reply With Quote
Old February 22nd, 2013, 07:44 PM   #52
sbcrichie
R&R Fabwerks
 
sbcrichie's Avatar
 
Join Date: 08-30-09
Location: sturgis/michigan
Posts: 1,206
iTrader: (8)
Mentioned: 2 Post(s)
Default

no i didnt do anything with this motor its a reman from the ford dealer. the last motor i just put new plugs in it and didnt have any problems with that one. i think the prob is mostly neglected motors that never get the plugs changed and either the plugs start to come loose and blow out or the threads get corroded and damaged when the plugs are removed.
sbcrichie is offline   Reply With Quote
Old February 22nd, 2013, 07:58 PM   #53
lsxzr2
zr2 with a lsx :)
 
lsxzr2's Avatar
 
Join Date: 10-21-11
Location: mi
Posts: 27
iTrader: (0)
Mentioned: 0 Post(s)
Default

Did you ever get the issue figured out and fixed? Very nice work, most people would have given up lol.
lsxzr2 is offline   Reply With Quote
Old February 22nd, 2013, 08:13 PM   #54
sbcrichie
R&R Fabwerks
 
sbcrichie's Avatar
 
Join Date: 08-30-09
Location: sturgis/michigan
Posts: 1,206
iTrader: (8)
Mentioned: 2 Post(s)
Default

been trying to get new reluctor ring for awhile now, dealer called today and said it was in so prob put it back together this week.
sbcrichie is offline   Reply With Quote
Old February 26th, 2013, 07:15 PM   #55
sbcrichie
R&R Fabwerks
 
sbcrichie's Avatar
 
Join Date: 08-30-09
Location: sturgis/michigan
Posts: 1,206
iTrader: (8)
Mentioned: 2 Post(s)
Default

well got the 99 reluctor ring but it wasnt a direct fit on the 03 motor they must have change the thickness of the cam chain gear. so i machined a 1/4" off the back of the reluctor ring and put the motor back together and it fired right up.
sbcrichie is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Rig Builds and Pics

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:24 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.20566 seconds with 66 queries