Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Quads, Bikes, and Sleds
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old December 6th, 2011, 02:18 PM   #1
whiterhino
I'm not old, honest...
 
whiterhino's Avatar
 
Join Date: 03-07-06
Location: Davisburg MI
Posts: 19,942
iTrader: (21)
Service at C&C sports in Brighton

Needing some service on my Rhino. Anybody had any experience good or badd with their service department?
__________________
GLFWDA member since 1979.
Member Southern Michigan Rock Crawlers.
whiterhino is offline   Reply With Quote
Old December 6th, 2011, 02:41 PM   #2
hosejockey4506
Visiting Admin
 
hosejockey4506's Avatar
 
Join Date: 11-04-05
Location: fenton
Posts: 8,706
iTrader: (42)
Had our plow quad fixed there last year, other then being 2 weeks out on work at the time no real complaint.
__________________
one of Michigans 99% er club.
hosejockey4506 is offline   Reply With Quote
Old December 6th, 2011, 02:42 PM   #3
High Center Hancho
rack tap re-rack click
 
High Center Hancho's Avatar
 
Join Date: 07-10-07
Location: Genesee County
Posts: 12,396
iTrader: (40)
what do you need done?
High Center Hancho is offline   Reply With Quote
Old December 6th, 2011, 02:56 PM   #4
Ridin Dirty
kixx007 wants to be me
 
Ridin Dirty's Avatar
 
Join Date: 12-11-07
Location: Metamora,Mi.
Posts: 8,904
iTrader: (149)
Quote:
Originally Posted by High Center Hancho View Post
what do you need done?
__________________
"It's all good. We've caught a lot nicer shit than this on fire"
Ridin Dirty is offline   Reply With Quote
Old December 6th, 2011, 04:25 PM   #5
whiterhino
I'm not old, honest...
 
whiterhino's Avatar
 
Join Date: 03-07-06
Location: Davisburg MI
Posts: 19,942
iTrader: (21)
just started leaking oil out the front ouput yoke under the engine. Looks like oil is seeping through the threads. Since there are no u-bolts on the joint, you have to press the u-joint apart while in place. Looks like a PITA.
__________________
GLFWDA member since 1979.
Member Southern Michigan Rock Crawlers.
whiterhino is offline   Reply With Quote
Old December 6th, 2011, 04:56 PM   #6
High Center Hancho
rack tap re-rack click
 
High Center Hancho's Avatar
 
Join Date: 07-10-07
Location: Genesee County
Posts: 12,396
iTrader: (40)
Quote:
Originally Posted by whiterhino View Post
just started leaking oil out the front ouput yoke under the engine. Looks like oil is seeping through the threads. Since there are no u-bolts on the joint, you have to press the u-joint apart while in place. Looks like a PITA.
I'm not sure on the Rhino's but that should have either a roll pin holding the yoke or its a slip yoke. Mine and Primal's RZR's are slip yoke and Dj's RZR4 has a roll pin...I will tell you that they are most likely going to charge you a shit ton of money to change that seal when you should be able to do it yourself on the cheap. I rebuilt Primal's RZR trans for him and it wasn't that bad...the parts cost him about $550, but the dealer wanted $1200 in labor. Polaris and the dealership are the same assholes that said you can't take out the trans without removing the motor...they were both wrong...if you want to attempt to do it yourself, give me a PM and I will help you on it
High Center Hancho is offline   Reply With Quote
Old December 6th, 2011, 05:09 PM   #7
High Center Hancho
rack tap re-rack click
 
High Center Hancho's Avatar
 
Join Date: 07-10-07
Location: Genesee County
Posts: 12,396
iTrader: (40)
okay never mind...it appears you do have to press the joint for removal...anywho here is a link for the factory manual

http://dl.dropbox.com/u/36292463/Rhi...%2006%20SE.pdf
High Center Hancho is offline   Reply With Quote
Old December 6th, 2011, 06:10 PM   #8
whiterhino
I'm not old, honest...
 
whiterhino's Avatar
 
Join Date: 03-07-06
Location: Davisburg MI
Posts: 19,942
iTrader: (21)
Yup, that's it. Come on over. I'll go fire up the furnace in the garage.
__________________
GLFWDA member since 1979.
Member Southern Michigan Rock Crawlers.
whiterhino is offline   Reply With Quote
Old December 6th, 2011, 08:21 PM   #9
High Center Hancho
rack tap re-rack click
 
High Center Hancho's Avatar
 
Join Date: 07-10-07
Location: Genesee County
Posts: 12,396
iTrader: (40)
Quote:
Originally Posted by whiterhino View Post
Yup, that's it. Come on over. I'll go fire up the furnace in the garage.
if you are serious about doing it let me know..we'll set a up a time to tear it down and fix it
High Center Hancho is offline   Reply With Quote
Old December 6th, 2011, 08:29 PM   #10
whiterhino
I'm not old, honest...
 
whiterhino's Avatar
 
Join Date: 03-07-06
Location: Davisburg MI
Posts: 19,942
iTrader: (21)
It's 1/4 torn apart. I have the u-joint caps off but can't get enough movement out of the driveshaft to rotate the joint out. I'm not a member of any atv forums but I just did some searching and I have to pull the front dif loose to pull the front driveshaft. Guess I'll dive back into it tomorrow. Problem is I don't know what seal is leaking. It's not the housing/yoke seal but looks like the oil is seeping down the threads. I don't know if these have a star type spline seal that goes under the nut or not. If not, I don't know what would make it start to leak all of a sudden.
__________________
GLFWDA member since 1979.
Member Southern Michigan Rock Crawlers.
whiterhino is offline   Reply With Quote
Old December 6th, 2011, 08:47 PM   #11
High Center Hancho
rack tap re-rack click
 
High Center Hancho's Avatar
 
Join Date: 07-10-07
Location: Genesee County
Posts: 12,396
iTrader: (40)
Quote:
Originally Posted by whiterhino View Post
It's 1/4 torn apart. I have the u-joint caps off but can't get enough movement out of the driveshaft to rotate the joint out. I'm not a member of any atv forums but I just did some searching and I have to pull the front dif loose to pull the front driveshaft. Guess I'll dive back into it tomorrow. Problem is I don't know what seal is leaking. It's not the housing/yoke seal but looks like the oil is seeping down the threads. I don't know if these have a star type spline seal that goes under the nut or not. If not, I don't know what would make it start to leak all of a sudden.
I was reading online that the front shaft seal is a common leak on those rhinos...I'd get it torn down and hopefully you can see the leak
High Center Hancho is offline   Reply With Quote
Old December 7th, 2011, 07:26 PM   #12
whiterhino
I'm not old, honest...
 
whiterhino's Avatar
 
Join Date: 03-07-06
Location: Davisburg MI
Posts: 19,942
iTrader: (21)
Well I got it apart and I really don't see what is wrong. There is no indication of leaking around the seal but rather through the spline and threads. There was no star seal for the spline so I don't understand how it didn't leak before and why it would just start leaking out of the blue. Is it common to put some type of silicone on the threads and spline?????
__________________
GLFWDA member since 1979.
Member Southern Michigan Rock Crawlers.
whiterhino is offline   Reply With Quote
Old December 7th, 2011, 07:40 PM   #13
xj97sport
atv rider
 
xj97sport's Avatar
 
Join Date: 01-08-08
Location: south west
Posts: 6,557
iTrader: (20)
I had this same issue on my freinds kodiak 450 on the rear out put seal leaking oil, i renewed the o ring, put white lithum on the splines before installing the seal and viola! no longer leaks oil faster than you can pour it in.

Btw, you know im doing a total tear down and rebuild on a rhino, pm if you need help, i know more than i care to about these things.
xj97sport is offline   Reply With Quote
Old December 7th, 2011, 07:47 PM   #14
whiterhino
I'm not old, honest...
 
whiterhino's Avatar
 
Join Date: 03-07-06
Location: Davisburg MI
Posts: 19,942
iTrader: (21)
There is no o-ring on this connection. Just a double lip seal on the yoke OD. Lithium grease will break down over time from the oil.
__________________
GLFWDA member since 1979.
Member Southern Michigan Rock Crawlers.
whiterhino is offline   Reply With Quote
Old December 7th, 2011, 07:52 PM   #15
xj97sport
atv rider
 
xj97sport's Avatar
 
Join Date: 01-08-08
Location: south west
Posts: 6,557
iTrader: (20)
pm sent
xj97sport is offline   Reply With Quote
Old December 7th, 2011, 09:39 PM   #16
redline8300
Redline8300
 
redline8300's Avatar
 
Join Date: 01-14-07
Location: Now Schererville, IN
Posts: 243
iTrader: (0)
I'd never go back there ever ever again. Two times messing up my sled and they aren't getting a third chance to mess something else up. Now I have a buddy who swears by them, but he has bought 4 sleds from them in about 12 years and has probably spent the price of 2 sleds in the service department, yes he is very hard on equipment, so maybe he gets great treatment.
redline8300 is offline   Reply With Quote
Old December 8th, 2011, 04:45 AM   #17
whiterhino
I'm not old, honest...
 
whiterhino's Avatar
 
Join Date: 03-07-06
Location: Davisburg MI
Posts: 19,942
iTrader: (21)
Well I was a little disappointed in the service dept when I talked to them. I told them I had removed the shrouds and I could see exactly where the oil was coming from. (the front output of the t-case) After not getting very clear answers on a price to replace a seal, he says "we'll have to look at it, it might be coming from the front differential". hmmmm......... I guess you didn't listen to me very well.

Anyway, I decided to fix it myself. Off to purchase a new seal today.
__________________
GLFWDA member since 1979.
Member Southern Michigan Rock Crawlers.
whiterhino is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Quads, Bikes, and Sleds
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 12:38 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.16532 seconds with 44 queries