Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old December 2nd, 2011, 05:35 AM   #1
trailbuggy
Member
 
Join Date: 08-03-10
Location: westland,mi
Posts: 44
iTrader: (0)
Mentioned: 0 Post(s)
Default 04 gmc troble code help

I have a 04 gmc serria with a 5.3. I got gas the other day and about 2 miles down the road got code 0171 bank 1 lean! notsure if the gas has an thing to do with it. But put dry gas in it , clean the MAF,looked for vacumm leaks sprayed carb cleaner around the intake and cleared the codes was good for one day now the same code 0171 and 0300 random misfire? Idles bad but drives fine! Should i rule out the gas? I am going to put more dry gas and change fuel filter today after work. any other thing to check?? thanks
trailbuggy is offline   Reply With Quote
Old December 3rd, 2011, 03:47 PM   #2
trailbuggy
Member
 
Join Date: 08-03-10
Location: westland,mi
Posts: 44
iTrader: (0)
Mentioned: 0 Post(s)
Default

think i got it fixed! bad o2 sensor
trailbuggy is offline   Reply With Quote
Old December 3rd, 2011, 04:07 PM   #3
joescamaro67
Senior Member
 
joescamaro67's Avatar
 
Join Date: 05-23-10
Location: chesaning mi usa
Posts: 731
iTrader: (18)
Mentioned: 1 Post(s)
Default

Sounds like a b1s1 oxygen sensor.
joescamaro67 is offline   Reply With Quote
Old December 3rd, 2011, 04:11 PM   #4
buttercr125
I work out
 
buttercr125's Avatar
 
Join Date: 02-10-09
Location: Fenton, mi
Posts: 2,549
iTrader: (25)
Mentioned: 0 Post(s)
Default

Sounds like the intake gasket is leaking. I know you said you checked it but you need to have a scanner hooked to it and watch your O2 readings and the LT and ST fuel trims when you spray it with carb cleaner.

Oh and your not looking for a vacuum leak, your looking for an air leak. Vacuum is not escaping out, air is forcing its way in.
__________________
If your thinking about dealing with JoshuaCripe read the link below first!!
http://www.greatlakes4x4.com/showthread.php?t=219276
buttercr125 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:37 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.07989 seconds with 18 queries