winch dead? - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old November 7th, 2011, 09:44 PM   #1
hman1991
Senior Member
 
hman1991's Avatar
 
Join Date: 02-04-06
Location: Holland Michigan
Posts: 474
iTrader: (7)
Mentioned: 0 Post(s)
Send a message via AIM to hman1991
Default winch dead?

i have 1 of those champion winches from costico. i was using it today and was going just fine, let off for a sec and went to hit button again and nothing. it just clicks no in or out or anything. is there anything i can check or am i just sol? maybe the brushes r shot? they are supposed to be the same as a ramsey. any ideas would be a great help. its on the front of my beater tracker and want to fix b4 i go out again.
hman1991 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old November 8th, 2011, 06:31 AM   #2
manicjester3
Senior Member
 
manicjester3's Avatar
 
Join Date: 08-15-08
Location: Brighton, MI
Posts: 274
iTrader: (8)
Mentioned: 0 Post(s)
Send a message via AIM to manicjester3 Send a message via Skype™ to manicjester3
Default

Just take it back to Costco and get a new one. Their return policy is unlimited time, no questions asked, other than "Would you like cash back or Costco Credit?"
__________________
Jeeps don't break things, their schedule for upgrading weak parts just gets a new time scale on occasion.
manicjester3 is offline   Reply With Quote
Old November 8th, 2011, 06:54 AM   #3
bigbchevy
missmrgreenagain
 
bigbchevy's Avatar
 
Join Date: 09-15-07
Location: fenton /hartland mi
Posts: 19,679
iTrader: (167)
Mentioned: 78 Post(s)
Default

Check the connections
__________________
H.o.r.e
(mr.green)So you are calling CC a liar?? Not a nice way to treat your bitch.
tube bending and gear installs pm me for info! gears installed for $150 and up per axle.
bigbchevy is offline   Reply With Quote
Old November 8th, 2011, 11:10 AM   #4
skife
Senior Member
 
skife's Avatar
 
Join Date: 02-12-07
Location: cedar springs mi
Posts: 5,122
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to skife Send a message via MSN to skife
Default

Quote:
Originally Posted by bigbchevy View Post
Check the connections
x2.


see if its getting power to the motor when you hit the button to engage it, if it doesn't its between the battery and the motor. if it does, the problem further down the line
skife is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:51 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.11642 seconds with 32 queries