Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old October 25th, 2011, 09:49 PM   #1
OpEd
B2
 
OpEd's Avatar
 
Join Date: 09-07-09
Location: Roseville Mi
Posts: 278
iTrader: (3)
B2 bogg down

so my truck has been driving good (besides trans leak) shifts fine rpms good evrything. the other day out of nowhere it just started bogging down really bad. it doesnt stall just sounds like complete ass. it hasnt done it till two days ago. i googled it and apparently its fuel related so i swapped out pump filter and sending unit yet it still is doing it. any suggestions i would appreciate it.
Thank you.
OpEd is offline   Reply With Quote
Old October 31st, 2011, 10:29 AM   #2
deathbypsi
Brian R.
 
deathbypsi's Avatar
 
Join Date: 08-08-07
Location: Temperance Mi
Posts: 2,019
iTrader: (16)
Send a message via AIM to deathbypsi
Check the fuel pump relay over by the air filter box. Will be 3 relays.1 for the ecm,1 for the pump and 1 for the a/c. The plugs are known to melt.
deathbypsi is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 02:32 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.06492 seconds with 14 queries