Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Quads, Bikes, and Sleds
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old October 10th, 2011, 06:21 AM   #1
IFS SUCKS
I like trees
 
IFS SUCKS's Avatar
 
Join Date: 09-20-07
Location: Lansing,MI
Posts: 5,796
iTrader: (6)
Mentioned: 0 Post(s)
Default 05 Yz125 coolant in oil.

I have 05 Yz125,and my radiator is empty and my trans is full of coolant.Is this a possible head-gasket or I see alot of water pump issues online?
IFS SUCKS is offline   Reply With Quote
Old October 10th, 2011, 06:43 AM   #2
TopGunn
Burried
 
TopGunn's Avatar
 
Join Date: 01-24-10
Location: Livonia
Posts: 248
iTrader: (1)
Mentioned: 0 Post(s)
Send a message via AIM to TopGunn Send a message via MSN to TopGunn
Default

Yep could be
TopGunn is offline   Reply With Quote
Old October 10th, 2011, 11:15 AM   #3
BadMoonRacing500
Freedom isn't Free
 
BadMoonRacing500's Avatar
 
Join Date: 09-11-10
Location: Harbor Springs MI
Posts: 714
iTrader: (0)
Mentioned: 0 Post(s)
Default

I'd say it's likely an impeller seal in the water pump.
BadMoonRacing500 is offline   Reply With Quote
Old October 11th, 2011, 07:48 AM   #4
ScOoTeR
hoo dat. wat.
 
ScOoTeR's Avatar
 
Join Date: 11-09-05
Location: Howell
Posts: 21,383
iTrader: (35)
Mentioned: 6 Post(s)
Default

From the nature of a 2-stroke's operation, a bad head gasket won't fill the trans with coolant.

I second BadMoon's assessment: rebuild the water pump.
__________________
@clarkstoncracker
ScOoTeR is online now   Reply With Quote
Old October 12th, 2011, 04:11 PM   #5
liv2mx
i like jungle gym's.
 
liv2mx's Avatar
 
Join Date: 11-10-05
Location: silver lake
Posts: 11,162
iTrader: (4)
Mentioned: 3 Post(s)
Default

crank seal.
liv2mx is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Quads, Bikes, and Sleds
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 04:31 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.08312 seconds with 20 queries