01 Cummins issue - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old September 28th, 2011, 12:04 PM   #1
974x4Taco
Flex Is OverRated
 
974x4Taco's Avatar
 
Join Date: 11-19-06
Location: Battle Creek
Posts: 2,007
iTrader: (7)
Mentioned: 0 Post(s)
Default 01 Cummins issue

Truck in question is a 01, 5speed, 135k miles, stock except airdog 100 and 4" turbo back exhaust.

The issue: truck has no power during acceleratio....none. When I take off from a stop driving normal ( I start in 2nd like most anybody else) the truck is fine untill you hit 11-1200 rpm and then it falls on its face, it will hardly gain speed. Then, once the rpms have built to around 16-1700, it is like you fliped a switch and it runs fine...will scream right to redline, but as soon as you upshift it does the same thing again.

It does not smoke (other than a little bit at start up), does not miss or studder, no codes or check engine light, I have fuel pressure, fuel mileage is good. It runs fine, it just has no power in the described situation.

My feeling is the injection pump is dieing but it has none of the classic symptoms and I have to toss a grand at a new pump if I dont need it.

Any help is appreciated
974x4Taco is online now   Reply With Quote
Old September 28th, 2011, 12:06 PM   #2
@_'-'
Senior Member
 
Join Date: 03-20-10
Location: MICHIGAN
Posts: 507
iTrader: (3)
Mentioned: 0 Post(s)
Default

delete

Last edited by @_'-'; September 30th, 2011 at 09:46 AM.
@_'-' is offline   Reply With Quote
Old September 28th, 2011, 12:22 PM   #3
974x4Taco
Flex Is OverRated
 
974x4Taco's Avatar
 
Join Date: 11-19-06
Location: Battle Creek
Posts: 2,007
iTrader: (7)
Mentioned: 0 Post(s)
Default

New.

Also put a known good check valve in the retuen in the pump with no change.
974x4Taco is online now   Reply With Quote
Old September 28th, 2011, 12:24 PM   #4
solid95yota
"the wonder truck"
 
solid95yota's Avatar
 
Join Date: 07-26-08
Location: new boston
Posts: 708
iTrader: (5)
Mentioned: 0 Post(s)
Default

Map sensor. Buddys truck just did that
solid95yota is offline   Reply With Quote
Old September 28th, 2011, 12:38 PM   #5
boggin-machine
Senior Member
 
boggin-machine's Avatar
 
Join Date: 01-11-06
Location: bay city
Posts: 11,639
iTrader: (31)
Mentioned: 0 Post(s)
Default

Turbo boost sensor. It won't always throw a code. Mine did the same thing. Depending on what connector is on the turbo around 190 for it.
__________________
08 qcsb Duramax Ltz
02 tj with some parts laying around **for sale**
08 crf 450 with a few goodies
boggin-machine is offline   Reply With Quote
Old September 28th, 2011, 12:54 PM   #6
974x4Taco
Flex Is OverRated
 
974x4Taco's Avatar
 
Join Date: 11-19-06
Location: Battle Creek
Posts: 2,007
iTrader: (7)
Mentioned: 0 Post(s)
Default

I just went down to the dodge dealer. They list the map sensor and the turbo boost sensor as the same pn. I ordered one @ 140$. Where is it located? Is it the sensor right up by the fuel filter that goes into the intake manifold?
974x4Taco is online now   Reply With Quote
Old September 28th, 2011, 03:05 PM   #7
solid95yota
"the wonder truck"
 
solid95yota's Avatar
 
Join Date: 07-26-08
Location: new boston
Posts: 708
iTrader: (5)
Mentioned: 0 Post(s)
Default

Yea it is the sensor right behind the fuel filter on the manifold. Has 3 wires going to a straight connector
solid95yota is offline   Reply With Quote
Old September 28th, 2011, 03:14 PM   #8
974x4Taco
Flex Is OverRated
 
974x4Taco's Avatar
 
Join Date: 11-19-06
Location: Battle Creek
Posts: 2,007
iTrader: (7)
Mentioned: 0 Post(s)
Default

Cool.

My ff canister is gone do to the airdog system so it should be a easy fix.
974x4Taco is online now   Reply With Quote
Old September 28th, 2011, 03:18 PM   #9
boggin-machine
Senior Member
 
boggin-machine's Avatar
 
Join Date: 01-11-06
Location: bay city
Posts: 11,639
iTrader: (31)
Mentioned: 0 Post(s)
Default

What did the cummins tech say? Was there a code thrown for it that don't pop the light?
__________________
08 qcsb Duramax Ltz
02 tj with some parts laying around **for sale**
08 crf 450 with a few goodies
boggin-machine is offline   Reply With Quote
Old September 28th, 2011, 04:27 PM   #10
974x4Taco
Flex Is OverRated
 
974x4Taco's Avatar
 
Join Date: 11-19-06
Location: Battle Creek
Posts: 2,007
iTrader: (7)
Mentioned: 0 Post(s)
Default

I never had a cummins tech look at it. I only went to the dealer to order the part.

I have checked it few times myself and there are no codes.


Both of you mentioned having the same issue be resolved by the sensor and some searching led me to many others so I am gonna give it a try.
974x4Taco is online now   Reply With Quote
Old September 28th, 2011, 04:37 PM   #11
big86inthestixx
Senior Member
 
big86inthestixx's Avatar
 
Join Date: 04-30-11
Location: howard city Mi
Posts: 2,085
iTrader: (9)
Mentioned: 2 Post(s)
Default

What about low boost, like a torn or leaking turbo boot. U usually have good torque and power until you get to where the turbo would normally kick in. If it were tore you would loose power until the turbo spooled up all the way and was ramming air through the tubes. Have seen this a few times on CTD's, sometimes the MAP sensor will sense low boost and sometimes it wont.
The map sensor, all u normally need to do is remove it and clean it, it gets fouled out just like a spark plug. If you are not getting a code then odds are good its working just not getting the correct reading because its dirty.

Sorry just my .02. All the above is personal experience.

P.S. Possible wastegate is stuck open or not moving as well
big86inthestixx is offline   Reply With Quote
Old September 28th, 2011, 06:36 PM   #12
974x4Taco
Flex Is OverRated
 
974x4Taco's Avatar
 
Join Date: 11-19-06
Location: Battle Creek
Posts: 2,007
iTrader: (7)
Mentioned: 0 Post(s)
Default

The boots are good, the waste gate moves free near as I can tell.
974x4Taco is online now   Reply With Quote
Old September 29th, 2011, 01:48 PM   #13
974x4Taco
Flex Is OverRated
 
974x4Taco's Avatar
 
Join Date: 11-19-06
Location: Battle Creek
Posts: 2,007
iTrader: (7)
Mentioned: 0 Post(s)
Default

The part came in and was wrong....the one they got had a round plug, mine has a flat plug. Now they tell me I need a sensor and a wireing harness and it will be 380$.

I took my money back. Anybody else have the flat connector, can I get that one for about the same cost as the other one?
974x4Taco is online now   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:01 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.15449 seconds with 61 queries