Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old October 4th, 2011, 07:36 PM   #1
Wheelman
Extreme Mudder
 
Wheelman's Avatar
 
Join Date: 09-05-08
Location: Pontiac, Michigan
Posts: 273
iTrader: (1)
Mentioned: 0 Post(s)
Default 2005 6.0 Diesel no power

I have a 2005 f-350 with a 6.0 all stock. Last weekend i was headed up north with a empty trailer. When i came off a red light the truck would barely move. Would not get more then 1000 rpm and no boost. I put it to the floor and it spit and shuddered just pouring out gray and black smoke that smelled like raw fuel. All of a sudden it took back off and ran fine. It keeps doing it intermittently when you let it coast or come to a stop.

Any help would be greatly appreciative.
Wheelman is offline   Reply With Quote
Old October 4th, 2011, 07:55 PM   #2
Fullsize4life
Kicking Cancers ASS
 
Fullsize4life's Avatar
 
Join Date: 07-25-06
Location: Hart, Mi (next to silver lake)
Posts: 18,757
iTrader: (7)
Mentioned: 0 Post(s)
Default

Take it in and have it scanned. There is a sensor that goes bad on them, cant remember what it is called.
Fullsize4life is offline   Reply With Quote
Old October 4th, 2011, 07:59 PM   #3
hamsmotorsports
Senior Member
 
hamsmotorsports's Avatar
 
Join Date: 03-07-09
Location: hazel park mi
Posts: 1,026
iTrader: (33)
Mentioned: 0 Post(s)
Default

Exhaust back pressure sensor could be plugged up. Also the egr valve might be full of carbon hanging up. Best to have it scanned first as it may direct you right to the problem.
hamsmotorsports is offline   Reply With Quote
Old October 4th, 2011, 08:03 PM   #4
Wheelman
Extreme Mudder
 
Wheelman's Avatar
 
Join Date: 09-05-08
Location: Pontiac, Michigan
Posts: 273
iTrader: (1)
Mentioned: 0 Post(s)
Default

Thanks i will take it in this week.
I was reading online that 04-05 and newer got rid of the ebp sensor?
i dont know if that is true or not.
Wheelman is offline   Reply With Quote
Old October 4th, 2011, 08:04 PM   #5
cvwindows
I think I can make it!!!!
 
cvwindows's Avatar
 
Join Date: 12-21-05
Location: Manitou Beach
Posts: 2,224
iTrader: (9)
Mentioned: 1 Post(s)
Default

I say it's injectors
cvwindows is offline   Reply With Quote
Old October 4th, 2011, 08:06 PM   #6
kickstand
sHaMoNe!
 
kickstand's Avatar
 
Join Date: 09-20-06
Location: fenton
Posts: 30,768
iTrader: (46)
Mentioned: 24 Post(s)
Default

hold on tight
kickstand is offline   Reply With Quote
Old October 4th, 2011, 08:11 PM   #7
natureboynate47
Senior Member
 
natureboynate47's Avatar
 
Join Date: 10-10-06
Location: oxford
Posts: 432
iTrader: (11)
Mentioned: 1 Post(s)
Default

Quote:
Originally Posted by Wheelman View Post
Thanks i will take it in this week.
I was reading online that 04-05 and newer got rid of the ebp sensor?
i dont know if that is true or not.
that is not correct. EBP sensor is used as input to control fuel and boost. Suburban Ford is just down the road from white lake. I'm sure there's someone there who could take a look at it for you.
natureboynate47 is offline   Reply With Quote
Old October 4th, 2011, 08:11 PM   #8
tlamphere
Mr. Jeep
 
tlamphere's Avatar
 
Join Date: 03-12-10
Location: jackson,michigan
Posts: 142
iTrader: (1)
Mentioned: 0 Post(s)
Default

we had the same thing going on in a 03 clean he egr. works very well
tlamphere is offline   Reply With Quote
Old October 4th, 2011, 08:13 PM   #9
Wheelman
Extreme Mudder
 
Wheelman's Avatar
 
Join Date: 09-05-08
Location: Pontiac, Michigan
Posts: 273
iTrader: (1)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by natureboynate47 View Post
that is not correct. EBP sensor is used as input to control fuel and boost. Suburban Ford is just down the road from white lake. I'm sure there's someone there who could take a look at it for you.
ya its been to Suburban Ford a few times for not wanting to start. I love the truck when it starts and runs right.
Wheelman is offline   Reply With Quote
Old October 4th, 2011, 08:31 PM   #10
natureboynate47
Senior Member
 
natureboynate47's Avatar
 
Join Date: 10-10-06
Location: oxford
Posts: 432
iTrader: (11)
Mentioned: 1 Post(s)
Default

It was kind of a joke. I work on diesels up there.
natureboynate47 is offline   Reply With Quote
Old October 4th, 2011, 08:34 PM   #11
Wheelman
Extreme Mudder
 
Wheelman's Avatar
 
Join Date: 09-05-08
Location: Pontiac, Michigan
Posts: 273
iTrader: (1)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by natureboynate47 View Post
It was kind of a joke. I work on diesels up there.
Then they do great work!! Honestly I cant complain about them they have always done good work for me.
Wheelman is offline   Reply With Quote
Old October 4th, 2011, 08:40 PM   #12
natureboynate47
Senior Member
 
natureboynate47's Avatar
 
Join Date: 10-10-06
Location: oxford
Posts: 432
iTrader: (11)
Mentioned: 1 Post(s)
Default

Thanks! Let me know if your bringing it in, I'll make sure to take care of it!
natureboynate47 is offline   Reply With Quote
Old October 4th, 2011, 08:58 PM   #13
mattt8430
Senior Member
 
Join Date: 09-20-11
Location: romulus mi
Posts: 135
iTrader: (5)
Mentioned: 0 Post(s)
Default

Egr valves sticking are very common
mattt8430 is offline   Reply With Quote
Old October 5th, 2011, 09:04 AM   #14
Elvis13
Senior Member
 
Join Date: 05-15-11
Location: Addison Township, MI
Posts: 1,173
iTrader: (7)
Mentioned: 0 Post(s)
Default

There is a rubber hose that comes off the passenger side of the intake that goes the map sensor. If its cut, clogged or reading incorrectly it will not read boost properly and also loose boost faster than you can make it.

The EBP is on the other side, it should be at about 17.5 idling.

You also have a VGT, if you DD your truck or idle too much, you may wear in a groove into your vanes adjustment. This may make your turbo vanes stick open and build no boost.
Elvis13 is offline   Reply With Quote
Old October 5th, 2011, 09:53 AM   #15
Elvis13
Senior Member
 
Join Date: 05-15-11
Location: Addison Township, MI
Posts: 1,173
iTrader: (7)
Mentioned: 0 Post(s)
Default

If it runs fine now you can bring it over. I can check your VGT, EBP, Boost pressure, EGR system and many other things in less than a minute.

Last edited by Elvis13; October 5th, 2011 at 10:43 AM.
Elvis13 is offline   Reply With Quote
Old October 5th, 2011, 10:03 AM   #16
Ridin Dirty
kixx007 wants to be me
 
Ridin Dirty's Avatar
 
Join Date: 12-11-07
Location: Metamora,Mi.
Posts: 8,923
iTrader: (149)
Mentioned: 0 Post(s)
Default

Ah yes... the joys of owning a 6.0. Sure do miss mine.
__________________
"It's all good. We've caught a lot nicer shit than this on fire"
Ridin Dirty is offline   Reply With Quote
Old October 5th, 2011, 12:03 PM   #17
Wheelman
Extreme Mudder
 
Wheelman's Avatar
 
Join Date: 09-05-08
Location: Pontiac, Michigan
Posts: 273
iTrader: (1)
Mentioned: 0 Post(s)
Default

i took the egr out this morning it was stuck open. I cleaned it but haven't got a chance to test drive it. Thanks for all the help.
Elvis13 i might take you up on this latter this week.
Wheelman is offline   Reply With Quote
Old October 5th, 2011, 12:17 PM   #18
Ridin Dirty
kixx007 wants to be me
 
Ridin Dirty's Avatar
 
Join Date: 12-11-07
Location: Metamora,Mi.
Posts: 8,923
iTrader: (149)
Mentioned: 0 Post(s)
Default

EGR Delete
__________________
"It's all good. We've caught a lot nicer shit than this on fire"
Ridin Dirty is offline   Reply With Quote
Old October 5th, 2011, 12:40 PM   #19
Wheelman
Extreme Mudder
 
Wheelman's Avatar
 
Join Date: 09-05-08
Location: Pontiac, Michigan
Posts: 273
iTrader: (1)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by Ridin Dirty View Post
EGR Delete
Ya thats next when i get some time.
Wheelman is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:27 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.15683 seconds with 50 queries