School me on XJ's..... - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old December 11th, 2005, 03:27 PM   #1
chris1044
Senior Member
 
chris1044's Avatar
 
Join Date: 11-05-05
Location: Lost in the mitten!
Posts: 2,012
iTrader: (4)
Mentioned: 0 Post(s)
Default School me on XJ's.....

I'm not a big jeep guy...I know the 4.0's a damn good engine that will go forever, and I needed a cheap beater so I picked up an 88 xj - 4.0, and I assume AX-15 (it's a stick), NP231?....The things just going to be a DD beater, so I dont really care much about it.

Anyhow, it's got some problems. First and foremost is the oil leak - pretty sure it's the valve cover gasket/oil pan gasket/ rear main. That's no biggy. But it's also got some 4wd issues.

The first "problem" is I can't get 4 low....no matter how far I pull back on the shift lever, it wont engage and stays in neutral....

The second problem is for some reason the part time light is staying on, with or without the thing in 4 hi, and occasionally it wont engage in 4 hi as well. I know it's got the vacuum shift fork on the axle, but that's "been replaced"....if the things in only 2wd and the part time lights on, does that mean the front axle is engaged? If so will it break anything to drive it like that for a while?

I havent even taken a look underneath to see what the problem could be, and I'm basically just asking if there is any known common occurance that would cause this (yes I know it could be alot of things), and if theres any other thing I should keep an eye out for..
chris1044 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old December 13th, 2005, 12:03 PM   #2
FlatFender
Tap Tap Splat
 
FlatFender's Avatar
 
Join Date: 11-05-05
Location: Raleigh NC
Posts: 15,782
iTrader: (1)
Mentioned: 2 Post(s)
Default

The transmission is most likely going to be the Puke-goat BA-10 The transmission normally has some problems with the second gear and stuff. Ite mostly regarded as junk. There are a few that have done well for a lot of miles, but not many.

Sometimes for 4 low you will need to put the tranny into neutral to get it back there.

If the light is staying on, its most likely a stuck switch.
FlatFender is offline   Reply With Quote
Old December 13th, 2005, 12:32 PM   #3
chris1044
Senior Member
 
chris1044's Avatar
 
Join Date: 11-05-05
Location: Lost in the mitten!
Posts: 2,012
iTrader: (4)
Mentioned: 0 Post(s)
Default

Yeah, I did some more research and found that the tranny is a peugot POS.

How hard is it to swap in the ax15 and whats needed? Just curious...
chris1044 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:39 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.08481 seconds with 29 queries