collapsed lifter :( Pics page 2 - Page 2 - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old July 19th, 2011, 10:32 PM   #21
Plato2k5
In Da Faaaaaace!!!
 
Plato2k5's Avatar
 
Join Date: 12-25-05
Location: WMU Kzoo Mi / Livonia, MI
Posts: 5,431
iTrader: (17)
Mentioned: 0 Post(s)
Send a message via AIM to Plato2k5
Default

I do run wallyworld oil. But I change it after every hard run. Maybe that has something to do with it.... I guess there can be a lot of variables. I'll see if i can find that article online though, thanks!
Plato2k5 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old July 21st, 2011, 09:07 PM   #22
Plato2k5
In Da Faaaaaace!!!
 
Plato2k5's Avatar
 
Join Date: 12-25-05
Location: WMU Kzoo Mi / Livonia, MI
Posts: 5,431
iTrader: (17)
Mentioned: 0 Post(s)
Send a message via AIM to Plato2k5
Default

Ok boys and girls here are the pics of the lifter. Pic of the cam dosn't show really anything but the lobe is worn a good bit.



Plato2k5 is offline   Reply With Quote
Old July 21st, 2011, 11:24 PM   #23
littletrucker
I'd hit that
 
littletrucker's Avatar
 
Join Date: 09-15-10
Location: Bear Lake 49614
Posts: 1,513
iTrader: (5)
Mentioned: 0 Post(s)
Default

That'll happen... I doubt it has anything to do with the oil you're running Shouldnt really matter after the cam is broken in.. Its all about the break in period with the right stuff


Do they make any kind of roller cam retrofits deals?
littletrucker is online now   Reply With Quote
Old July 21st, 2011, 11:34 PM   #24
Plato2k5
In Da Faaaaaace!!!
 
Plato2k5's Avatar
 
Join Date: 12-25-05
Location: WMU Kzoo Mi / Livonia, MI
Posts: 5,431
iTrader: (17)
Mentioned: 0 Post(s)
Send a message via AIM to Plato2k5
Default

who knows what is to blame. I don't think running wally world oil helps any as i've heard it degrades quick. I'll start throwing in zinc additives as I do not want to repeat this.

They do, however its not worth the cost. I bought a howards cam and lifters which will arrive in the morning ;)
Plato2k5 is offline   Reply With Quote
Old July 22nd, 2011, 07:52 PM   #25
hamsmotorsports
Senior Member
 
hamsmotorsports's Avatar
 
Join Date: 03-07-09
Location: hazel park mi
Posts: 1,033
iTrader: (34)
Mentioned: 1 Post(s)
Default

Change your oil several times when you get it running all that metal is somewhere in your engine. Hopefully most is in the filter, but you do not want it tearing up the rods and mains hopefully it hasent allready because it dont take long.
hamsmotorsports is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:12 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.10968 seconds with 35 queries