1995 ranger 4.0 no spark on cyl 6 - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old June 3rd, 2011, 09:11 PM   #1
92comanche4x4
Senior Member
 
92comanche4x4's Avatar
 
Join Date: 03-27-08
Location: carleton, mi
Posts: 933
iTrader: (11)
Mentioned: 0 Post(s)
Default 1995 ranger 4.0 no spark on cyl 6

I have a 1995 ranger 4.0 4x4 it has no spark on the number 6cyl. i replaced the ecm, coil pack, plug wire, plug. and its getting fuel and has good compression. any ideas
92comanche4x4 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old June 3rd, 2011, 09:13 PM   #2
GREASYHANDS
arachnis deathacis
 
GREASYHANDS's Avatar
 
Join Date: 03-16-09
Location: Ravenna
Posts: 12,837
iTrader: (28)
Mentioned: 18 Post(s)
Default

Broken tooth on the crank reluctor wheel?

Do you have injector pulse on cly 6?
__________________
Bare Bones Offroad
RIP FS4L
Pavement sucks
Meow
GREASYHANDS is online now   Reply With Quote
Old June 3rd, 2011, 10:00 PM   #3
92comanche4x4
Senior Member
 
92comanche4x4's Avatar
 
Join Date: 03-27-08
Location: carleton, mi
Posts: 933
iTrader: (11)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by GREASYHANDS View Post
Broken tooth on the crank reluctor wheel?

Do you have injector pulse on cly 6?

Im not sure on the injector pulse. and what is a crank reluctor wheel?
92comanche4x4 is offline   Reply With Quote
Old June 3rd, 2011, 10:12 PM   #4
GREASYHANDS
arachnis deathacis
 
GREASYHANDS's Avatar
 
Join Date: 03-16-09
Location: Ravenna
Posts: 12,837
iTrader: (28)
Mentioned: 18 Post(s)
Default

The crank reluctor is behind the harmonic balancer. The crankshaft position sensor "reads" each tooth on this to tell the ecm what cly is top dead center. This also works with the cam sensor to set timing and the fuel to the correct cly at the correct time.
__________________
Bare Bones Offroad
RIP FS4L
Pavement sucks
Meow
GREASYHANDS is online now   Reply With Quote
Old June 3rd, 2011, 10:16 PM   #5
GREASYHANDS
arachnis deathacis
 
GREASYHANDS's Avatar
 
Join Date: 03-16-09
Location: Ravenna
Posts: 12,837
iTrader: (28)
Mentioned: 18 Post(s)
Default

__________________
Bare Bones Offroad
RIP FS4L
Pavement sucks
Meow
GREASYHANDS is online now   Reply With Quote
Old June 3rd, 2011, 10:28 PM   #6
92comanche4x4
Senior Member
 
92comanche4x4's Avatar
 
Join Date: 03-27-08
Location: carleton, mi
Posts: 933
iTrader: (11)
Mentioned: 0 Post(s)
Default

Could it be just the cam sensor thats what i was thinking to do next. And i had no clue what a crank reluctor was im gonna have to check it out tommarow. how would i get to it take the harmonic balancer off?
92comanche4x4 is offline   Reply With Quote
Old June 3rd, 2011, 10:50 PM   #7
GREASYHANDS
arachnis deathacis
 
GREASYHANDS's Avatar
 
Join Date: 03-16-09
Location: Ravenna
Posts: 12,837
iTrader: (28)
Mentioned: 18 Post(s)
Default

you can see the reluctor with out taking any thing off the motor. Use a socket and turn the engine over while looking closely at the teeth on the wheel. If any of them look damaged replace it. Also check your injection pulse before you start to throw parts at it.
__________________
Bare Bones Offroad
RIP FS4L
Pavement sucks
Meow
GREASYHANDS is online now   Reply With Quote
Old June 4th, 2011, 09:27 AM   #8
92comanche4x4
Senior Member
 
92comanche4x4's Avatar
 
Join Date: 03-27-08
Location: carleton, mi
Posts: 933
iTrader: (11)
Mentioned: 0 Post(s)
Default

cool thank you for the help im gonna check it out today
92comanche4x4 is offline   Reply With Quote
Old June 4th, 2011, 11:10 AM   #9
chris1044
Senior Member
 
chris1044's Avatar
 
Join Date: 11-05-05
Location: Lost in the mitten!
Posts: 2,012
iTrader: (4)
Mentioned: 0 Post(s)
Default

IIRC cam sensor doesn't do anything with spark, just injection timing, but I can't remember and don't have schematics in front of me.

Have you swapped a plug wire to see if it's just a bad wire? Perhaps you got a bad coil pack?
chris1044 is offline   Reply With Quote
Old June 4th, 2011, 02:48 PM   #10
92comanche4x4
Senior Member
 
92comanche4x4's Avatar
 
Join Date: 03-27-08
Location: carleton, mi
Posts: 933
iTrader: (11)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by chris1044 View Post
IIRC cam sensor doesn't do anything with spark, just injection timing, but I can't remember and don't have schematics in front of me.

Have you swapped a plug wire to see if it's just a bad wire? Perhaps you got a bad coil pack?
plug wire and another coil pack have been swapped on
92comanche4x4 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:48 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.10806 seconds with 50 queries