94 F150 4x4 jerking - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old May 11th, 2011, 12:03 AM   #1
chevyk10
FORD / GM
 
chevyk10's Avatar
 
Join Date: 11-21-09
Location: Howell
Posts: 891
iTrader: (0)
Mentioned: 1 Post(s)
Default 94 F150 4x4 jerking

Looking at buying a nice 94 extended cab 4x4 f150, but I noticed that the front end jerks pretty bad when making tight turns even when the 4x4 is NOT engaged. Any idea what would cause this?
chevyk10 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old May 11th, 2011, 12:16 AM   #2
mudrunner78
Senior Member
 
mudrunner78's Avatar
 
Join Date: 04-15-10
Location: Memphis/ MI
Posts: 239
iTrader: (2)
Mentioned: 0 Post(s)
Default

Hubs are staying engauged
mudrunner78 is offline   Reply With Quote
Old May 11th, 2011, 06:27 AM   #3
chevyk10
FORD / GM
 
chevyk10's Avatar
 
Join Date: 11-21-09
Location: Howell
Posts: 891
iTrader: (0)
Mentioned: 1 Post(s)
Default

Quote:
Originally Posted by mudrunner78 View Post
Hubs are staying engauged
What would cause that and how could you fix it? It has automatic locking hubs. This would be my first 4x4 so I don't know too much about them.
chevyk10 is offline   Reply With Quote
Old May 11th, 2011, 08:55 AM   #4
Quiefinator
go'til itsounds expensive
 
Join Date: 02-27-07
Location: Romeo
Posts: 987
iTrader: (5)
Mentioned: 0 Post(s)
Default

Buy manual lockouts and throw those automatics in the garbage. my .02
Quiefinator is offline   Reply With Quote
Old May 11th, 2011, 09:02 AM   #5
FORD FLARESIDE
Ohh, that's gonna' hurt
 
FORD FLARESIDE's Avatar
 
Join Date: 04-09-06
Location: Comstock Park
Posts: 21,875
iTrader: (24)
Mentioned: 9 Post(s)
Default

Might want to check the Trailing arm bushings at the bracket near the frame, or check to see if the trailing arm is rotted out on the bottom side next to the torsion beam.
Attached Thumbnails
Click image for larger version

Name:	0923101836a.jpg
Views:	64
Size:	68.4 KB
ID:	78770  

Last edited by FORD FLARESIDE; May 11th, 2011 at 09:05 AM.
FORD FLARESIDE is offline   Reply With Quote
Old May 11th, 2011, 04:59 PM   #6
chevyk10
FORD / GM
 
chevyk10's Avatar
 
Join Date: 11-21-09
Location: Howell
Posts: 891
iTrader: (0)
Mentioned: 1 Post(s)
Default

Quote:
Originally Posted by FORD FLARESIDE View Post
Might want to check the Trailing arm bushings at the bracket near the frame, or check to see if the trailing arm is rotted out on the bottom side next to the torsion beam.
Ok thanks I'll check it out. The truck only has 105k miles and was driven only buy 2 older guys so its in damn good shape. Not much rust on the underside either so I'm gussing the hubs are just crap.
chevyk10 is offline   Reply With Quote
Old May 11th, 2011, 11:07 PM   #7
Daddy Dan
SBF Nut
 
Daddy Dan's Avatar
 
Join Date: 11-18-08
Location: Fowlerville/Michigan
Posts: 887
iTrader: (32)
Mentioned: 0 Post(s)
Default

My 2wd just had the eccentric ring in the radius arm bushing break. Its a 2wd and does this. Plus, those bushings could easily be rotted out by now. Or, automatic hubs are known to seize or break.

How many F150s have you had now?
Daddy Dan is offline   Reply With Quote
Old May 11th, 2011, 11:12 PM   #8
chevyk10
FORD / GM
 
chevyk10's Avatar
 
Join Date: 11-21-09
Location: Howell
Posts: 891
iTrader: (0)
Mentioned: 1 Post(s)
Default

Quote:
Originally Posted by Daddy Dan View Post
My 2wd just had the eccentric ring in the radius arm bushing break. Its a 2wd and does this. Plus, those bushings could easily be rotted out by now. Or, automatic hubs are known to seize or break.

How many F150s have you had now?
We found out the linkage is messed up for the floor shifter and it was in 4wd the whole time even though it was set to 2wd lol. Easy fix. And at least 10. Can't pass up a great deal like this though. 4x4 ext cab 351 with 105k miles and very little rust for $1,500.

Last edited by chevyk10; December 27th, 2011 at 11:08 PM.
chevyk10 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:25 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.16079 seconds with 47 queries