Ever See This Before? - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old August 13th, 2010, 08:57 AM   #1
All5ofus
Senior Member
 
All5ofus's Avatar
 
Join Date: 08-02-07
Location: Temperance/Michigan
Posts: 2,792
iTrader: (13)
Mentioned: 0 Post(s)
Default Ever See This Before?

I have a 2005 Dodge Dakota with 3.7 ltr I had come in 2 weeks ago with a bad power steering pump (leaking bad). Well it turns out the little plastic hose between the resivour and pump melted causing the leak. I put the new pump on and the steering still felt SUPER hard still to move so I assume we need to replace the Rack.

[IMG][/IMG]

I started to put the new one on last night. First I unthreaded the high preasure hose and expected the hose to fall off the fitting on the rack. Well even with the fitting threaded all the way off and pushed back a inch this wouldn't come of without some force. After I got it off I found this 1.5" plastic chunk hanging out the end. Hmmm. I thought this isn't supose to be here. I grabbed a pair of plires and had to give it hell to get another 1.5" of the plastic to pull out. Then due to pulling on it so hard it broke off and I still have some in there.

Anyway . . . my question is "Has anyone ever seen this before? Would you know what it might be? Did it belong in there?" It was blocking the flow by at least 80%.

[IMG][/IMG]
All5ofus is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old August 13th, 2010, 02:50 PM   #2
All5ofus
Senior Member
 
All5ofus's Avatar
 
Join Date: 08-02-07
Location: Temperance/Michigan
Posts: 2,792
iTrader: (13)
Mentioned: 0 Post(s)
Default

Help
All5ofus is offline   Reply With Quote
Old August 13th, 2010, 03:05 PM   #3
SANDVIPR
Yeeeee Haaaaw!
 
SANDVIPR's Avatar
 
Join Date: 09-10-06
Location: Holland
Posts: 7,462
iTrader: (58)
Mentioned: 5 Post(s)
Default

I'm not that framilliar with that year Dakota, but I am with that Saginaw TC pump. That's either from the resivour or the rack. There's nothing like that inside one of those pumps.....
SANDVIPR is offline   Reply With Quote
Old August 15th, 2010, 04:20 PM   #4
All5ofus
Senior Member
 
All5ofus's Avatar
 
Join Date: 08-02-07
Location: Temperance/Michigan
Posts: 2,792
iTrader: (13)
Mentioned: 0 Post(s)
Default

I'm thinking it might be a liner from in the hose.
All5ofus is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:00 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.29662 seconds with 32 queries