89 F150 No Kickdown - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old May 23rd, 2010, 05:36 PM   #1
Drg racr
Senior Member
 
Drg racr's Avatar
 
Join Date: 12-09-06
Location: Bellevue, MI
Posts: 418
iTrader: (1)
Mentioned: 0 Post(s)
Default 89 F150 No Kickdown

I was driving the 89 F150 today, and I noticed that when you mash the accelerator, it doesn't kick down. It will let the motor rev when I get into it, though. Any ideas? I just changed the trans fluid and filter. It's a 351W/C6 combo.
Drg racr is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old May 23rd, 2010, 06:00 PM   #2
bigblockford79
Big Block Ranger
 
bigblockford79's Avatar
 
Join Date: 05-11-08
Location: Hamilton, MI
Posts: 2,741
iTrader: (24)
Mentioned: 0 Post(s)
Default

Is the kickdown cable/lever hooked up, does the lever in the trans move freely. If it does, check the vacuum modulator in the rear of the trans on the passenger side just above the oil pan. Pull the hose off from it and check for fluid. if you have fluid coming out or any evidence of fluid ever being there, it needs to be replaced.
__________________
If you can read this, thank a teacher. If you can read it while pooping, thank Bill Gates!

"A girls butt hole is like a 9 volt battery. You know its wrong, but eventually you put your tongue on it."
bigblockford79 is offline   Reply With Quote
Old May 23rd, 2010, 07:18 PM   #3
Drg racr
Senior Member
 
Drg racr's Avatar
 
Join Date: 12-09-06
Location: Bellevue, MI
Posts: 418
iTrader: (1)
Mentioned: 0 Post(s)
Default

The modulator looks good, but it looks like the kickdown cable is out of adjustment. At full throttle, the cable just barely moves (like maybe 1/8"). I'll have to try to remember how to adjust it.
Drg racr is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:26 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.08596 seconds with 29 queries