Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old April 10th, 2010, 04:25 PM   #1
Jeepunk95
Senior Member
 
Join Date: 10-21-08
Location: Galien MI
Posts: 375
iTrader: (1)
Mentioned: 0 Post(s)
Default Transmission problem

OK so i did something against my better judgment and changed trans fluid in my Jasper 4l60e wiht over 150k on it this was bad idea #1. Any how drove it fine for about 1k miles or so since then no problems till today first time its been driven since last trailer pull. Drove to the gas station all was ok on the way home started getting a really bad flare up in RPM between 2nd and 3rd got home realized it appears the rear trans seal blew out checked the fluid it was way over full oops. ok so drained some fluid checked again all ok. The problem is while idling in drive or reverse i hear a clicking and bad noise coming from transmission mind you when i drianed the fluid it was very hot!! smoking.
Well basically now ive figured i need to either rebuild or replace leaning towards replace because im thinking the clicking noise i here is possibily broken planetary set in trnasmission. any input owuld be appreciated. thank you.
Jeepunk95 is offline   Reply With Quote
Old April 22nd, 2010, 10:16 PM   #2
Lousypirate
Yo
 
Lousypirate's Avatar
 
Join Date: 02-11-08
Location: Marne 49435
Posts: 10,471
iTrader: (31)
Mentioned: 23 Post(s)
Default

sounds more like sun gear to me? much easier to break, buddy of mine grenaded the sun gear in his 4l60e...
Lousypirate is online now   Reply With Quote
Old April 22nd, 2010, 10:18 PM   #3
Junkyard
Senior Member
 
Junkyard's Avatar
 
Join Date: 01-13-10
Location: Brighton, Mi
Posts: 336
iTrader: (6)
Mentioned: 0 Post(s)
Default

if you want a new one let me know i work at a trans shop and can prolly get you a 100% rebuilt one for like $600
Junkyard is offline   Reply With Quote
Old May 1st, 2010, 08:42 PM   #4
Jeepunk95
Senior Member
 
Join Date: 10-21-08
Location: Galien MI
Posts: 375
iTrader: (1)
Mentioned: 0 Post(s)
Default

ok thanx for the replies i will keep you in mind junkyard but right now the u-pull it LKQ yard in southbend said they will sel ltrans and tc for 134.00 so maybe enough to get by for now while i rebuild my old one.
Jeepunk95 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 01:52 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.09448 seconds with 18 queries