99 cummins engine light - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old November 25th, 2009, 09:05 PM   #1
boggin-machine
Senior Member
 
boggin-machine's Avatar
 
Join Date: 01-11-06
Location: bay city
Posts: 11,648
iTrader: (31)
Mentioned: 0 Post(s)
Default 99 cummins engine light

throw a code p0237

the code days the map sensor has a low voltage.
dealer says theres no part number for map sensor.
code also states that the ecm has detected that intake air pressure below a calibrated value to long.

truck still runs good. still smokes tires through 3rd gear. stilling boosting around 42 pounds.

it also states that it could be a turbo boost sensor. but thats for a ford or gm product. not a cummins product.
boggin-machine is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old November 25th, 2009, 09:52 PM   #2
frdboy
Wishin' I waz fishin'
 
frdboy's Avatar
 
Join Date: 03-29-06
Location: Grand Haven, MI
Posts: 10,952
iTrader: (25)
Mentioned: 9 Post(s)
Default

Not sure if it is your problem but there is a MAP sensor, rear of intake.

__________________
Cheap Thrills Off Road

2003 F-250 4X4 7.3 PSD Crew Cab

1971 Bronco
frdboy is offline   Reply With Quote
Old November 25th, 2009, 09:57 PM   #3
boggin-machine
Senior Member
 
boggin-machine's Avatar
 
Join Date: 01-11-06
Location: bay city
Posts: 11,648
iTrader: (31)
Mentioned: 0 Post(s)
Default

ill go mess with it in a few when the truck cools down.
boggin-machine is offline   Reply With Quote
Old January 14th, 2010, 11:27 AM   #4
DodgeitRamit
Senior Member
 
DodgeitRamit's Avatar
 
Join Date: 05-12-06
Location: Paw Paw
Posts: 248
iTrader: (2)
Mentioned: 0 Post(s)
Default

You are boosting 42 PSI?? What turbo do you have . . . HX35??


I just had a few codes pop up on mine (234, 238) for overboost on my 99, after injector install so I threw a boost fooler on to keep the CEL off and outta limp mode. But anyways . . . are you running an oiled air filter?? Also look on Ebay I saw one the other day for 25 dollars . . . and they give all the part numbers (Mopar and Cummins) too.
DodgeitRamit is offline   Reply With Quote
Old January 14th, 2010, 04:36 PM   #5
Monkeyevil
I <3 Miatas
 
Monkeyevil's Avatar
 
Join Date: 11-05-05
Location: Kalamazoo, MI
Posts: 8,987
iTrader: (16)
Mentioned: 2 Post(s)
Send a message via AIM to Monkeyevil
Default

Do you have a programmer? Most plug in at the MAP sensor. 42lbs is over boosting your turbo (if it's stock) by about 7 PSI. It's not doing anything but making hot air and shortening it's live.
__________________
JcrOffroad
Zoom Zoom!
Monkeyevil is offline   Reply With Quote
Old January 14th, 2010, 05:05 PM   #6
boggin-machine
Senior Member
 
boggin-machine's Avatar
 
Join Date: 01-11-06
Location: bay city
Posts: 11,648
iTrader: (31)
Mentioned: 0 Post(s)
Default

its not a stock turbo. its a 68 mm turbo
boggin-machine is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:46 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.11963 seconds with 38 queries