4.3 S-series jimmy/blazers - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old October 5th, 2009, 11:59 PM   #1
98ZJ318
RIP 2-15 12:20 AM
 
98ZJ318's Avatar
 
Join Date: 06-05-08
Location: Kalamazoo/other
Posts: 1,637
iTrader: (11)
Mentioned: 0 Post(s)
Default 4.3 S-series jimmy/blazers

took my gmc jimmy into the shop after my engine started to have what i suspected a rod knock,says he thinks its a cracked flywheel? Would that sound the same? anybody else ever have an issue with this as well?
98ZJ318 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old October 6th, 2009, 02:20 AM   #2
CHVYPWR
D.I.L.L.I.G.A.F.
 
CHVYPWR's Avatar
 
Join Date: 11-05-05
Location: Vicksburg, Mi.
Posts: 1,650
iTrader: (12)
Mentioned: 0 Post(s)
Default

A cracked flexplate would sound similar to a spun rod bearing.
CHVYPWR is offline   Reply With Quote
Old October 6th, 2009, 07:58 AM   #3
jbsjunk
Wheelies
 
jbsjunk's Avatar
 
Join Date: 03-01-08
Location: Almost Allendale Mi
Posts: 16,900
iTrader: (36)
Mentioned: 20 Post(s)
Default

Yes, a cracked flexplate can make the same noise. Same with loose converter bolts.
jbsjunk is offline   Reply With Quote
Old October 6th, 2009, 09:25 AM   #4
Kodiak450r
Keep on truckin
 
Kodiak450r's Avatar
 
Join Date: 11-14-07
Location: Waterford, MI
Posts: 5,911
iTrader: (19)
Mentioned: 1 Post(s)
Default

it could be either. 4.3s seem to have a common problem of spun bearings if the oil level gets low.
Kodiak450r is offline   Reply With Quote
Old October 6th, 2009, 03:14 PM   #5
98ZJ318
RIP 2-15 12:20 AM
 
98ZJ318's Avatar
 
Join Date: 06-05-08
Location: Kalamazoo/other
Posts: 1,637
iTrader: (11)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by Kodiak450r View Post
it could be either. 4.3s seem to have a common problem of spun bearings if the oil level gets low.
thats the thing, the oil never got low or ran out,just dirty...i figured itd be loose bolts but he still thinks its a cracked flywheel so we'll find out in a week or 2
98ZJ318 is offline   Reply With Quote
Old October 7th, 2009, 12:14 AM   #6
Yota Bill
Senior Member
 
Join Date: 08-24-08
Location: Morrice, Mi
Posts: 3,229
iTrader: (11)
Mentioned: 0 Post(s)
Default

remove the bellhousing inspection cover and spin the engine over by hand, and take a look...if the bolts are loose, you will see shiny metal around them, if the plate is cracked...well, you'll see a crack...
Yota Bill is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:51 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.13174 seconds with 38 queries