Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old October 1st, 2009, 07:51 PM   #1
mudrunner456
Senior Member
 
mudrunner456's Avatar
 
Join Date: 10-29-06
Location: north muskegon, MI
Posts: 731
iTrader: (7)
Mentioned: 0 Post(s)
Default just bought a mustang runs funny

picked up 87 mustang 5.0 5 speed the body isnt the greatest but it runs good, sorta. it idles fine and drives good but when i floor it the car will take off but once it hits about 3500 rpm it falls right on its face. Let off the gas a bit and it picks right back up. Only messed with it for a few minutes so as far as i know i could be anything. The exhaust stinks bad like old gas so im hoping to get it out and put fresh in it will take care of it. any other suggestions?
mudrunner456 is offline   Reply With Quote
Old October 1st, 2009, 07:57 PM   #2
rentalrider
Senior Member
 
rentalrider's Avatar
 
Join Date: 11-13-07
Location: West Branch, Mi
Posts: 1,035
iTrader: (3)
Mentioned: 0 Post(s)
Default

Nice. I love those old fox body 'stangs. I have and '86 5.0HO in my jeep cj and have an '89 freshly dipped, waiting for me to decide what heads, etc I'm gonna put on it. You might want to use the mustang forums after you try fresh gas and the other obvious fixes. They've been really helpful to me when chasing gremlins. If you need anything, shoot me a pm and I'll point you towards the forum I used. Post pics up!
rentalrider is offline   Reply With Quote
Old October 2nd, 2009, 12:16 AM   #3
Big Bad Black X
Member
 
Join Date: 09-23-09
Location: Chicago
Posts: 79
iTrader: (0)
Mentioned: 0 Post(s)
Default

Fuel pump is my bet. Make sure you clean out the fuel tank if you end up putting a new one in. Find someone to let you use a fuel pressure gauge, you can easily tap into the schradder valve on the fuel rail. If you cant find one you can borrow that you can see while driving you may have to have a buddy ride under the hood while you floor it and watch the gauge lol. I had to do this once, long story, and yeah, bad idea lol.
Big Bad Black X is offline   Reply With Quote
Old October 2nd, 2009, 05:41 AM   #4
Rob the plumber
Licensed master plumber
 
Rob the plumber's Avatar
 
Join Date: 06-14-06
Location: New Baltimore, Michigan
Posts: 5,570
iTrader: (32)
Mentioned: 1 Post(s)
Default

Check engine light on?

I'd check the MAP sensor, TPS sensor, and the condition of the plugswires/wires/cap/rotor.
Rob the plumber is offline   Reply With Quote
Old October 2nd, 2009, 05:50 AM   #5
davidkassie
Senior Member
 
davidkassie's Avatar
 
Join Date: 01-29-09
Location: coloma michigan
Posts: 773
iTrader: (6)
Mentioned: 0 Post(s)
Default

the ignition coil likes to break down at higher rpms, just a thought!
davidkassie is offline   Reply With Quote
Old October 2nd, 2009, 06:19 AM   #6
Nuggets
I fix stuff!
 
Nuggets's Avatar
 
Join Date: 09-15-06
Location: Bay City, MI
Posts: 13,369
iTrader: (13)
Mentioned: 2 Post(s)
Default

Take rubbing compound and place it on the blue oval part of the vehicle. Rub vigorously until removed. Place GM logo in its place. Car should run ok now.

Just kidding, they are cool cars. I would drain the old fuel and put some fresh stuff in. I would also change the fuel filter. Next place I would look would be fuel pressure.

Good luck.
Nuggets is offline   Reply With Quote
Old October 2nd, 2009, 11:33 AM   #7
Big Bad Black X
Member
 
Join Date: 09-23-09
Location: Chicago
Posts: 79
iTrader: (0)
Mentioned: 0 Post(s)
Default

New filter is a good idea, I would start there if fresh gas didn't help. Easy and it probably needs it anyway.
Big Bad Black X is offline   Reply With Quote
Old October 2nd, 2009, 05:37 PM   #8
mudrunner456
Senior Member
 
mudrunner456's Avatar
 
Join Date: 10-29-06
Location: north muskegon, MI
Posts: 731
iTrader: (7)
Mentioned: 0 Post(s)
Default

yea just ut in the fresh gas, gotta go run it. got a pressure gauge gonna check that to. what should it have for pressure?
mudrunner456 is offline   Reply With Quote
Old October 2nd, 2009, 10:38 PM   #9
Nuggets
I fix stuff!
 
Nuggets's Avatar
 
Join Date: 09-15-06
Location: Bay City, MI
Posts: 13,369
iTrader: (13)
Mentioned: 2 Post(s)
Default

Quote:
Originally Posted by mudrunner456 View Post
yea just ut in the fresh gas, gotta go run it. got a pressure gauge gonna check that to. what should it have for pressure?
Off the top of my head I'd say 35-40 psi. Test in line off the test port. Test port is located on the fuel rail over top of the injectors. Sticking a screwdriver in the shrader valve of the test port and watching fuel spray out is not a confirmation of acceptable fuel pressure.

Fords use their own size test port on the fuel rail. If you have a standard pressure tester, you will be out of luck.

Last edited by Nuggets; October 2nd, 2009 at 10:58 PM.
Nuggets is offline   Reply With Quote
Old October 2nd, 2009, 10:47 PM   #10
1978f-150
village idiot
 
1978f-150's Avatar
 
Join Date: 07-08-09
Location: white lake Michagan
Posts: 128
iTrader: (0)
Mentioned: 0 Post(s)
Default

id check the fuel pressure regulater fuel pump or the filter i had similer problem in my 79 hatchback when i did the injection swap
1978f-150 is offline   Reply With Quote
Old October 8th, 2009, 05:49 PM   #11
Big Bad Black X
Member
 
Join Date: 09-23-09
Location: Chicago
Posts: 79
iTrader: (0)
Mentioned: 0 Post(s)
Default

Make sure you watch teh fuel pressure at higher RPM under load where you had a problem. When my 5.0 thunderbird had a high RPM miss it showed good fuel pressure till it was under load and RPM came up and the fuel pressure just sank after a certain point.
Big Bad Black X is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 01:32 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.17974 seconds with 32 queries