water pump leak - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old September 30th, 2009, 01:19 PM   #1
currdogg
Member
 
currdogg's Avatar
 
Join Date: 01-31-09
Location: Sault Ste. Marie Ont
Posts: 83
iTrader: (1)
Mentioned: 0 Post(s)
Default water pump leak

HI, i just put my water pump back in and it leaks from the weep hole under the fan shaft. is this normal? do i need a new pump?
Should i shoot it with a .44?
currdogg is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old September 30th, 2009, 01:23 PM   #2
IFS SUCKS
I like trees
 
IFS SUCKS's Avatar
 
Join Date: 09-20-07
Location: Lansing,MI
Posts: 5,796
iTrader: (6)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by currdogg View Post
HI, i just put my water pump back in and it leaks from the weep hole under the fan shaft. is this normal? do i need a new pump?
Should i shoot it with a .44?
Why did you have it out?
IFS SUCKS is offline   Reply With Quote
Old September 30th, 2009, 01:26 PM   #3
currdogg
Member
 
currdogg's Avatar
 
Join Date: 01-31-09
Location: Sault Ste. Marie Ont
Posts: 83
iTrader: (1)
Mentioned: 0 Post(s)
Default

well, i took it out cuz it was leaking and i thought it would be the gaskets. so i took 'er all apart and did them with new gasket. it seemed fine when i let it run a bit when i finished it, but today i let it run a lil longer and found the peeing out the weep hole. i dont know crap from crayons, this is my first time even seeing a water pump!!
currdogg is offline   Reply With Quote
Old September 30th, 2009, 01:28 PM   #4
Bishop
Senior Member
 
Bishop's Avatar
 
Join Date: 04-12-07
Location: brighton, atlanta, MI
Posts: 3,590
iTrader: (15)
Mentioned: 0 Post(s)
Send a message via AIM to Bishop
Default

its junk. thats why that hole is there. if its leaking from there, it needs replacement.
Bishop is offline   Reply With Quote
Old September 30th, 2009, 01:28 PM   #5
IFS SUCKS
I like trees
 
IFS SUCKS's Avatar
 
Join Date: 09-20-07
Location: Lansing,MI
Posts: 5,796
iTrader: (6)
Mentioned: 0 Post(s)
Default

Replace it!
IFS SUCKS is offline   Reply With Quote
Old September 30th, 2009, 01:29 PM   #6
currdogg
Member
 
currdogg's Avatar
 
Join Date: 01-31-09
Location: Sault Ste. Marie Ont
Posts: 83
iTrader: (1)
Mentioned: 0 Post(s)
Default

Thank you.
currdogg is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:44 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.11520 seconds with 38 queries