Windshield Wiper Motor - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old September 16th, 2009, 01:22 PM   #1
92ChvyK5Blazer
Newbie
 
Join Date: 05-14-09
Location: Royal Oak Michigan
Posts: 23
iTrader: (0)
Mentioned: 0 Post(s)
Default Windshield Wiper Motor

Hey guys,

My windshield wiper motor in 1992 chevy k5 blazer is all messed up...I am looking for a fix that doesnt require me to change the motor out, if thats possible...

Whats wrong with it: Sometimes it works perfectly fine...other times, I will put it on the first setting(the slowest one) and it will keep going as if it was on the fastest setting, and won't stop unless I turn the truck off. Other times I will turn them on and nothing will happen...It will just make a loud "whirrr" sound, and wont stop until I turn the truck off...

Any suggestions on this?

Thanks alot,

John
92ChvyK5Blazer is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old September 16th, 2009, 03:15 PM   #2
Disturban
Senior Member
 
Disturban's Avatar
 
Join Date: 02-28-08
Location: Lowell, MI
Posts: 2,794
iTrader: (2)
Mentioned: 0 Post(s)
Default

Might not be the motor, it might be the switch.
Disturban is offline   Reply With Quote
Old September 16th, 2009, 03:17 PM   #3
IFS SUCKS
I like trees
 
IFS SUCKS's Avatar
 
Join Date: 09-20-07
Location: Lansing,MI
Posts: 5,796
iTrader: (6)
Mentioned: 0 Post(s)
Default

Module
IFS SUCKS is offline   Reply With Quote
Old September 16th, 2009, 05:13 PM   #4
pitbull2332
Senior Member
 
pitbull2332's Avatar
 
Join Date: 02-02-09
Location: scotts,mi
Posts: 1,166
iTrader: (28)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by IFS SUCKS View Post
Module
X2
pitbull2332 is offline   Reply With Quote
Old September 16th, 2009, 05:31 PM   #5
Yetti
Buy a Fiat! Save the UAW!
 
Yetti's Avatar
 
Join Date: 11-05-05
Location: 20 minutes south of Hell...
Posts: 14,388
iTrader: (10)
Mentioned: 2 Post(s)
Default

pull the card out of the module and clean the burnt grease off the brushes.
__________________
Yetti
Yetti is offline   Reply With Quote
Old September 16th, 2009, 05:38 PM   #6
IFS SUCKS
I like trees
 
IFS SUCKS's Avatar
 
Join Date: 09-20-07
Location: Lansing,MI
Posts: 5,796
iTrader: (6)
Mentioned: 0 Post(s)
Default

Some of those had a special policy, pm me your vin and I'll check.
IFS SUCKS is offline   Reply With Quote
Old September 16th, 2009, 06:07 PM   #7
92ChvyK5Blazer
Newbie
 
Join Date: 05-14-09
Location: Royal Oak Michigan
Posts: 23
iTrader: (0)
Mentioned: 0 Post(s)
Default

Thank you for all the input, unfortunately I left for college yesterday, and did not take the blazer up, I took my silverado up instead...Where excatly would I find the module? and IFS SUCKS, When i go home next I will get that VIN number, but that won't be until the first week in october )=

Thanks for the input though, its all been quite helpful.

John
92ChvyK5Blazer is offline   Reply With Quote
Old September 16th, 2009, 06:50 PM   #8
Yetti
Buy a Fiat! Save the UAW!
 
Yetti's Avatar
 
Join Date: 11-05-05
Location: 20 minutes south of Hell...
Posts: 14,388
iTrader: (10)
Mentioned: 2 Post(s)
Default

The vin would be on your registration if its in your wallet?
__________________
Yetti
Yetti is offline   Reply With Quote
Old September 16th, 2009, 07:16 PM   #9
92ChvyK5Blazer
Newbie
 
Join Date: 05-14-09
Location: Royal Oak Michigan
Posts: 23
iTrader: (0)
Mentioned: 0 Post(s)
Default

Its not )= I left the wallet one at home because I figured I wouldnt need it...and my dad was gonna drive the truck during the winter so he wanted it for his wallet.. )=
92ChvyK5Blazer is offline   Reply With Quote
Old September 16th, 2009, 08:59 PM   #10
davidkassie
Senior Member
 
davidkassie's Avatar
 
Join Date: 01-29-09
Location: coloma michigan
Posts: 821
iTrader: (7)
Mentioned: 0 Post(s)
Default

the wiper control module is the plastic cover on the motor itself, cleaning may work, may not, didn't work for me before, its a cheap repair and easy to do, i would just change it! david
davidkassie is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:21 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.16909 seconds with 50 queries