Dakota rear squeak - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old July 18th, 2009, 11:22 PM   #1
xNewhaven11
Four Wheel Drive
 
xNewhaven11's Avatar
 
Join Date: 02-01-09
Location: Lenox Twp, Michigan
Posts: 703
iTrader: (6)
Mentioned: 0 Post(s)
Send a message via AIM to xNewhaven11 Send a message via MSN to xNewhaven11
Default Dakota rear squeak

Was out at the Berville figure 8 until it started pouring rain so we went to a friends house down the road to wait while it passed. on the way there i hit a puddle and hydroplaned which caused the truck to drift some, i caught it and had it undercontrol. The whole way back to the figure 8 and home, whenever i turn i hear a pretty loud squeak coming from the rear end. everything looks fine but i cant seem to pinpoint it. The truck is dirty from the dirt roads so it may be dirt/debris clogged somewhere, i am hitting the carwash in the morning so i will see.

It is an 05 dodge Dakota.
Any ideas?

Thanks.
xNewhaven11 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old July 19th, 2009, 10:28 AM   #2
xNewhaven11
Four Wheel Drive
 
xNewhaven11's Avatar
 
Join Date: 02-01-09
Location: Lenox Twp, Michigan
Posts: 703
iTrader: (6)
Mentioned: 0 Post(s)
Send a message via AIM to xNewhaven11 Send a message via MSN to xNewhaven11
Default

took it to the high pressure car wash and blew the under body and wheels out for 7mins, then ran it through the car wash with the underbody spray and it seems to be fine.
xNewhaven11 is offline   Reply With Quote
Old July 20th, 2009, 09:41 PM   #3
xNewhaven11
Four Wheel Drive
 
xNewhaven11's Avatar
 
Join Date: 02-01-09
Location: Lenox Twp, Michigan
Posts: 703
iTrader: (6)
Mentioned: 0 Post(s)
Send a message via AIM to xNewhaven11 Send a message via MSN to xNewhaven11
Default

Started squeaking again, narrowed it down to the rear driver wheel, or something around there. Took of the tire, and drum. There was one shiny spot on the inside and the rest looked normal. Took a file and cleaned up all the rust, dirt, and debris all around the edge.
Drove around in circles, took sharp and wide turns, was fine for about 20miles, then it started again....I dont know what else to do now. Maybe a new drum?
99% of the time it only squeaks/grinds when im turning right.
xNewhaven11 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:51 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.10706 seconds with 29 queries