Banks Torque Tube cracked - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech
GL4x4 Live! GL4x4 Casino is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Thread Tools Search this Thread
Old July 12th, 2009, 04:12 PM   #1
zjguy721's Avatar
Join Date: 04-13-06
Location: Hartland/Milford, MI
Posts: 1,117
iTrader: (2)
Mentioned: 0 Post(s)
Default Banks Torque Tube cracked

What is everyone's opinion on this:

'98 ZJ with 4.0, put a Banks header on @ 78,000 miles. Started to get kind of loud last fall, figured it was the gasket, maybe I didn't torque things down right, etc. Was garaged for the winter, took it apart today to change the gasket, and the manifold is cracked. Two of the welds, can see daylight when looking in through the downtube.

So, considering it only has 14,000 miles on it, do you think this is poor workmanship, or is my Jeep running too hot (or some other issue)? Runs at about 210, same as always, never have any overheating issues.

I'm going to have my neighbor (who is a mechanic for a sprint car team, so has experience welding these types of things, where I don't) reweld it up for me, but do you think I have a gripe with Banks on this one?

So, first, is this an issue with the Jeep? Second, if not, do you think I should call Banks and gripe?
zjguy721 is offline   Reply With Quote
Sponsored Links
Old July 12th, 2009, 04:52 PM   #2
Kicking Cancers ASS
Fullsize4life's Avatar
Join Date: 07-25-06
Location: Hart, Mi (next to silver lake)
Posts: 18,754
iTrader: (7)
Mentioned: 1 Post(s)

Call banks and see what they say. If they wont do shit then weld it and see what happens

Best Car & Motorcycle Insurance | Auto/Moto Protection Today | FREE Trade-In Quote
Fullsize4life is offline   Reply With Quote
Old July 12th, 2009, 05:29 PM   #3
nixxerRsixxer's Avatar
Join Date: 11-06-05
Location: humanresources
Posts: 3,280
iTrader: (1)
Mentioned: 0 Post(s)
Send a message via ICQ to nixxerRsixxer Send a message via AIM to nixxerRsixxer Send a message via Yahoo to nixxerRsixxer

.. pretty sure this was a pretty common problem when this header came out.. figured they fixed it by now.. maybe old batch?
He had a steady job and watched what he spent.
He'd say I don't believe in payin' no goddamn rent.
I'll squirrel away every goddamn cent
and buy my own damn house in Kalamazoo.
nixxerRsixxer is offline   Reply With Quote
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 10:20 PM.

Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.10751 seconds with 31 queries