Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old June 30th, 2009, 10:28 AM   #1
camccardell
tiger blood
 
camccardell's Avatar
 
Join Date: 10-14-08
Location: Homer MI
Posts: 1,345
iTrader: (20)
Mentioned: 1 Post(s)
Default 99 suburban electrical question

hey guys my wifes suburban is acting funny again. The turn signal works, but after you turn, you can hear the flasher still clicking on and off even though the lights aren't flashing.

Any ideas on why it is doing this or how to fix it?

I was doing it a few months ago, but it went away. I don't think it is going to go away this time.

Chris
camccardell is offline   Reply With Quote
Old June 30th, 2009, 10:42 AM   #2
firehawk
Live Action!
 
firehawk's Avatar
 
Join Date: 10-02-07
Location: Clawson, Michigan
Posts: 12,285
iTrader: (43)
Mentioned: 5 Post(s)
Default

Grand Ams do that too, or something similar.


I have read to replace the turn signal switch.


Not sure if it applies, but it might.
firehawk is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:44 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.05793 seconds with 14 queries