Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > Great Lakes 4x4 Marketplace > Wanted
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old May 6th, 2009, 07:48 PM   #1
JUSS10
4given4x4.com
 
JUSS10's Avatar
 
Join Date: 04-09-06
Location: Zeeland, MI
Posts: 501
iTrader: (4)
Mentioned: 0 Post(s)
Default YJ Speedometer

My dads speedo stopped on his 95 YJ. we replaced the speed sensor and still nothing so if anyone has a speedo around let me know. thanks

Justin
JUSS10 is offline   Reply With Quote
Old May 6th, 2009, 07:50 PM   #2
clarkstoncracker
lol
 
clarkstoncracker's Avatar
 
Join Date: 11-03-05
Location: OC - MI
Posts: 42,291
iTrader: (39)
Mentioned: 71 Post(s)
Send a message via AIM to clarkstoncracker
Default

what does the back of your gauge look like? post a pic
__________________
clarkstoncracker is offline   Reply With Quote
Old May 7th, 2009, 03:25 PM   #3
Bton
Senior Member
 
Bton's Avatar
 
Join Date: 01-29-09
Location: Grandville,MI/ but now Crystal lake,IL
Posts: 141
iTrader: (0)
Mentioned: 0 Post(s)
Default

same thing happened to my 92 and the back of the speedo looks fine, still haven't figured it out. I replaced the sensor and checked the connections.
Bton is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > Great Lakes 4x4 Marketplace > Wanted
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 12:49 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.07616 seconds with 16 queries