2001 F-150 Cruise Control - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old March 4th, 2009, 05:57 AM   #1
bigblue2230
still goin
 
bigblue2230's Avatar
 
Join Date: 11-08-05
Location: Royal Oak
Posts: 940
iTrader: (11)
Mentioned: 0 Post(s)
Default 2001 F-150 Cruise Control

The cruise control on my truck quit working, and when I push the SET button, the cruise light flashes once, and then nothing happens. has anyone runinto this before, or know what it might be? It's cold out still and the less time standing out there checking wires the better.

2001 F-150 crew cab.
5.4L 4x4
Auto trans.
bigblue2230 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old March 4th, 2009, 07:22 AM   #2
Medic8
You call, we haul.
 
Medic8's Avatar
 
Join Date: 11-08-05
Location: Southgate, MI
Posts: 1,496
iTrader: (5)
Mentioned: 0 Post(s)
Default

First big thing... have someone tap the brake pedal while you watch the brake lights. If your brake pedal switch is non-functioning/ malfunctioning, it will affect the operation of your cruise control.

Is your MIL (Check Engine) light on? Or is your Overdrive Off light on constantly/ flashing? If so, you've got a Diagnostic Trouble Code (DTC) set somewhere that might be an indication of a problem. For example, VSS (Vehicle Speed Sensor), TPS (Throttle Position Sensor)... those could affect your cruise control operation as well.

I just looked on the Ford Service website and it says that according to your symptoms (Light flashes once after you press the SET button, no "dynamic pull" meaning your truck doesn't accellerate briefly then settle into speed, and no function of speed control) it's most likely the control cable or the servo motor.

It says to check the speed control cable for proper connection at both ends, then to check and make sure the cable isn't kinked or binding. If the cable operates freely and is connected properly, it's most likely the servo motor itself.
Medic8 is offline   Reply With Quote
Old March 4th, 2009, 05:01 PM   #3
bigblue2230
still goin
 
bigblue2230's Avatar
 
Join Date: 11-08-05
Location: Royal Oak
Posts: 940
iTrader: (11)
Mentioned: 0 Post(s)
Default

Ok, no DTC's, brake lights work, and cable is connected and has no kinks/binds. Guess I will try finding a new motor or one someone can lend me to try. THanks
bigblue2230 is offline   Reply With Quote
Old March 4th, 2009, 05:04 PM   #4
big burt
Senior Member
 
big burt's Avatar
 
Join Date: 11-02-06
Location: novi mi 48377
Posts: 1,269
iTrader: (14)
Mentioned: 0 Post(s)
Send a message via AIM to big burt
Default

Have You Had The 05s28 Recall Done? Its A Speed Controul Modification That Was A Recall On Your Year. Try That. You Can Call It Into Any Ford Dealer.
big burt is offline   Reply With Quote
Old March 4th, 2009, 09:04 PM   #5
Fullsize4life
Kicking Cancers ASS
 
Fullsize4life's Avatar
 
Join Date: 07-25-06
Location: Hart, Mi (next to silver lake)
Posts: 18,754
iTrader: (7)
Mentioned: 0 Post(s)
Default

x2 on the recall. Mine still needs it.
Fullsize4life is offline   Reply With Quote
Old March 4th, 2009, 09:05 PM   #6
HVYRTFT
Reed my teef
 
HVYRTFT's Avatar
 
Join Date: 01-17-07
Location: Whitehall,MI
Posts: 2,475
iTrader: (9)
Mentioned: 1 Post(s)
Default

X2 on the recall, hope it doesn't catch on fire!!!
HVYRTFT is offline   Reply With Quote
Old March 21st, 2009, 11:27 PM   #7
ASEBlackFx4
Member
 
ASEBlackFx4's Avatar
 
Join Date: 02-08-09
Location: Wyandotte, MI
Posts: 69
iTrader: (1)
Mentioned: 0 Post(s)
Default

Another thing to add is if you use the tilt function regularly, the wires that run down the column like to break, seen that a couple times.
ASEBlackFx4 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:07 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.12255 seconds with 43 queries