Ranger stalling - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old March 18th, 2009, 09:52 PM   #1
kp99xj
Senior Member
 
kp99xj's Avatar
 
Join Date: 02-20-09
Location: Marietta, Ga
Posts: 343
iTrader: (3)
Mentioned: 0 Post(s)
Default Ranger stalling

94 ranger 4.0 with a 5 spd stick. The gf called today and said it stalls when ever she lets the clutch out and can hardly even shift into gear. I have not had a chance to look at it until the this coming weekend. Also the trans fluid level is full and was changed with last oil change. new cluth last year. I am just wondering what might cause this and what to look at.
kp99xj is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old March 19th, 2009, 01:00 PM   #2
deathbypsi
Brian R.
 
deathbypsi's Avatar
 
Join Date: 08-08-07
Location: Temperance Mi
Posts: 2,026
iTrader: (16)
Mentioned: 0 Post(s)
Send a message via AIM to deathbypsi
Default

Look for a massive vac leak or check the IAC solenoid on the upper intake. The one on my 99 crapped out a while back and wouldnt let it idle below 2k.
deathbypsi is offline   Reply With Quote
Old March 19th, 2009, 04:37 PM   #3
fsumotorhead
N8KVB
 
fsumotorhead's Avatar
 
Join Date: 10-24-06
Location: Flat Rock, MI
Posts: 4,186
iTrader: (34)
Mentioned: 0 Post(s)
Default

check the parking brake
fsumotorhead is offline   Reply With Quote
Old March 19th, 2009, 08:05 PM   #4
bikerted86
Member
 
Join Date: 07-28-07
Location: dearborn hts.
Posts: 96
iTrader: (0)
Mentioned: 0 Post(s)
Default

sounds like a clutch issue if it doesnt want to go into gear. Make sure the clutch master is full of fluid.
bikerted86 is offline   Reply With Quote
Old March 19th, 2009, 08:16 PM   #5
booblinker
Trailer Trash
 
booblinker's Avatar
 
Join Date: 10-29-06
Location: Leonard, mi
Posts: 9,869
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to booblinker
Default

Quote:
Originally Posted by bikerted86 View Post
sounds like a clutch issue if it doesnt want to go into gear. Make sure the clutch master is full of fluid.
Yea maybe low on clutch fluid? Did the slave cylinder get changed with the clutch, I know those are really common to leak. And if its low, it like the clutch is an on/off switch, so if you don't have enough throttle its gonna stall out cus its like dropping the clutch.
__________________
-2001 Tahoe original 5.3 4x4 only 435k
-Down to 2 three wheelers
-1985 V65 Magna
-1978 F100
-1973 CT70 with 125cc motor
booblinker is offline   Reply With Quote
Old March 19th, 2009, 09:00 PM   #6
Fraser
Senior Member
 
Fraser's Avatar
 
Join Date: 12-12-06
Location: Howell/Hartland
Posts: 4,194
iTrader: (27)
Mentioned: 0 Post(s)
Send a message via AIM to Fraser
Default

Quote:
Originally Posted by booblinker View Post
Yea maybe low on clutch fluid? Did the slave cylinder get changed with the clutch, I know those are really common to leak. And if its low, it like the clutch is an on/off switch, so if you don't have enough throttle its gonna stall out cus its like dropping the clutch.
X2
Fraser is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:47 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.14766 seconds with 40 queries