Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old February 11th, 2009, 03:16 PM   #1
dodson
Senior Member
 
dodson's Avatar
 
Join Date: 10-24-08
Location: Sturgis, MI
Posts: 388
iTrader: (2)
Mentioned: 0 Post(s)
Default 03 f150 5.4L

i have a 03 f150 with the 5.4L when i start it up it idles normal but when i put it in gear and give it gas it days right away... anybody have a idea what it could be???
dodson is offline   Reply With Quote
Old February 11th, 2009, 04:00 PM   #2
Yota Bill
Senior Member
 
Join Date: 08-24-08
Location: Morrice, Mi
Posts: 3,229
iTrader: (11)
Mentioned: 0 Post(s)
Default

you mean it dies when you give it throttle only when in gear, but will rev normally when in P or N, or that it dies as soon as you put it in gear?
Yota Bill is offline   Reply With Quote
Old February 11th, 2009, 05:39 PM   #3
04 EDGE
Floor Shift Maddness!
 
04 EDGE's Avatar
 
Join Date: 01-08-08
Location: Westland Mi
Posts: 1,372
iTrader: (7)
Mentioned: 0 Post(s)
Send a message via AIM to 04 EDGE
Default

sounds like maybe the air duct from the MAF to the TB is not connected right.
04 EDGE is offline   Reply With Quote
Old February 11th, 2009, 06:03 PM   #4
liv2mx
i like jungle gym's.
 
liv2mx's Avatar
 
Join Date: 11-10-05
Location: silver lake
Posts: 11,162
iTrader: (4)
Mentioned: 3 Post(s)
Default

the selonoid packs on the plugs will do that if they are bad.does it stay running just does not have and power under load? find a auto zone and plug it in.that will tell you what it is.if it's a selonoid it will tell you what one.
liv2mx is offline   Reply With Quote
Old February 12th, 2009, 09:59 AM   #5
dodson
Senior Member
 
dodson's Avatar
 
Join Date: 10-24-08
Location: Sturgis, MI
Posts: 388
iTrader: (2)
Mentioned: 0 Post(s)
Default

thanks guys figured it out
dodson is offline   Reply With Quote
Old February 12th, 2009, 07:23 PM   #6
04 EDGE
Floor Shift Maddness!
 
04 EDGE's Avatar
 
Join Date: 01-08-08
Location: Westland Mi
Posts: 1,372
iTrader: (7)
Mentioned: 0 Post(s)
Send a message via AIM to 04 EDGE
Default

what was it?
04 EDGE is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 05:31 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.07199 seconds with 22 queries