95 bronco not right - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old December 31st, 2008, 01:21 AM   #1
masterbeatty
Senior Member
 
masterbeatty's Avatar
 
Join Date: 03-04-08
Location: my house
Posts: 4,209
iTrader: (17)
Mentioned: 6 Post(s)
Default 95 bronco not right

well after a new fuel pump, tune up and some good cleaning i took the truck out for a ride today and it will not hold a shift out past about 3 grand. if i shift it manualy it does fine but if i try and let the trans work it just shifts early. any ideas? tps maby?
masterbeatty is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old December 31st, 2008, 07:38 AM   #2
booblinker
Trailer Trash
 
booblinker's Avatar
 
Join Date: 10-29-06
Location: Leonard, mi
Posts: 10,369
iTrader: (5)
Mentioned: 2 Post(s)
Send a message via AIM to booblinker
Default

Does it still have normal amount of power, just doesn't shift?
__________________
-2001 Tahoe original 5.3 4x4 only 435k
-Down to 2 three wheelers
-1985 V65 Magna
-1978 F100
-1973 CT70 with 125cc motor
booblinker is offline   Reply With Quote
Old December 31st, 2008, 06:09 PM   #3
masterbeatty
Senior Member
 
masterbeatty's Avatar
 
Join Date: 03-04-08
Location: my house
Posts: 4,209
iTrader: (17)
Mentioned: 6 Post(s)
Default

o yea runs real well.
masterbeatty is offline   Reply With Quote
Old January 1st, 2009, 10:24 AM   #4
masterbeatty
Senior Member
 
masterbeatty's Avatar
 
Join Date: 03-04-08
Location: my house
Posts: 4,209
iTrader: (17)
Mentioned: 6 Post(s)
Default

well lastnite it pulled about 4 grand and shifted but then would not do it again.
masterbeatty is offline   Reply With Quote
Old January 2nd, 2009, 09:33 AM   #5
booblinker
Trailer Trash
 
booblinker's Avatar
 
Join Date: 10-29-06
Location: Leonard, mi
Posts: 10,369
iTrader: (5)
Mentioned: 2 Post(s)
Send a message via AIM to booblinker
Default

What trans, I know those ford trans's had lots of electrical problems, check out fullsizebronco.Com, there is a shit ton of people there that have had trans problems.
__________________
-2001 Tahoe original 5.3 4x4 only 435k
-Down to 2 three wheelers
-1985 V65 Magna
-1978 F100
-1973 CT70 with 125cc motor
booblinker is offline   Reply With Quote
Old January 2nd, 2009, 10:31 PM   #6
big_ol_bronco78
Psalm 40:2
 
big_ol_bronco78's Avatar
 
Join Date: 12-27-08
Location: Grand Rapids, MI
Posts: 3,303
iTrader: (46)
Mentioned: 0 Post(s)
Default

yeah, go to fullsizebronco.com, i'm a member on there, a lot of guys with ton's of bronco knowledge. if it's the e4od might be something in wiring, not telling it to shift right, if it's AOD, might need to adjust cable.
big_ol_bronco78 is offline   Reply With Quote
Old January 3rd, 2009, 01:02 AM   #7
masterbeatty
Senior Member
 
masterbeatty's Avatar
 
Join Date: 03-04-08
Location: my house
Posts: 4,209
iTrader: (17)
Mentioned: 6 Post(s)
Default

im on there to. yea i searched around. its an e4od im guna take it and pull codes and see what that gives me.
masterbeatty is offline   Reply With Quote
Old January 3rd, 2009, 01:21 AM   #8
big_ol_bronco78
Psalm 40:2
 
big_ol_bronco78's Avatar
 
Join Date: 12-27-08
Location: Grand Rapids, MI
Posts: 3,303
iTrader: (46)
Mentioned: 0 Post(s)
Default

thats a good way to start. sounds like maybe a sensor or something, something not reading RPM's correctly
big_ol_bronco78 is offline   Reply With Quote
Old January 5th, 2009, 08:15 AM   #9
masterbeatty
Senior Member
 
masterbeatty's Avatar
 
Join Date: 03-04-08
Location: my house
Posts: 4,209
iTrader: (17)
Mentioned: 6 Post(s)
Default

well now it runs fine until about 4200 and it drops. it wont hold any gear out. i put an air intake on it and i went out and blew the rear driveshaft up so ill have to wait to see if that helps at all until i fix the shaft
masterbeatty is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:05 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.10458 seconds with 47 queries