explodes coolant - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old October 28th, 2008, 01:11 AM   #1
88mudder
In the band!
 
Join Date: 03-30-06
Location: waterford michigan
Posts: 3,678
iTrader: (29)
Mentioned: 0 Post(s)
Send a message via AIM to 88mudder Send a message via Skype™ to 88mudder
Default explodes coolant

302 v8 with foxbody mustang 3 core radiator. Whenever i drive the truck and shut it off it will explode coolant out the cap for a few seconds then stop...13 psi cap not sure what psi cap is needed, am i off?
88mudder is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old October 28th, 2008, 02:13 AM   #2
Daniel
SFA Ranger
 
Daniel's Avatar
 
Join Date: 01-28-08
Location: Livonia
Posts: 1,142
iTrader: (8)
Mentioned: 0 Post(s)
Default

Maybe your cap is junk, they do go bad.

Go and get a good one, not one of the ones with the stupid lever thing.
Daniel is offline   Reply With Quote
Old October 28th, 2008, 01:43 PM   #3
88mudder
In the band!
 
Join Date: 03-30-06
Location: waterford michigan
Posts: 3,678
iTrader: (29)
Mentioned: 0 Post(s)
Send a message via AIM to 88mudder Send a message via Skype™ to 88mudder
Default

i have a mustang radiator and from what ive read they use a 16 psi cap and the cap on there now is a 13psi..
88mudder is offline   Reply With Quote
Old October 28th, 2008, 04:35 PM   #4
Yetti
Buy a Fiat! Save the UAW!
 
Yetti's Avatar
 
Join Date: 11-05-05
Location: 20 minutes south of Hell...
Posts: 14,387
iTrader: (10)
Mentioned: 2 Post(s)
Default

the cap is low for the usage. it should be a 15-18 and the antifreeze sould read -30* on a tester. if its higher or lower you will have issues. it maybe the block has a trapped air bubble also.
__________________
Yetti
Yetti is offline   Reply With Quote
Old October 28th, 2008, 05:16 PM   #5
88mudder
In the band!
 
Join Date: 03-30-06
Location: waterford michigan
Posts: 3,678
iTrader: (29)
Mentioned: 0 Post(s)
Send a message via AIM to 88mudder Send a message via Skype™ to 88mudder
Default

Quote:
Originally Posted by Yetti View Post
the cap is low for the usage. it should be a 15-18 and the antifreeze sould read -30* on a tester. if its higher or lower you will have issues. it maybe the block has a trapped air bubble also.
i just picked up a 16 psi cap so ill try that out, im sure that my old cap was the culprit. I read the application guide for the 16psi cap and it shows for all 302v8's so thats what i got.
88mudder is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:57 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.10572 seconds with 35 queries