valve cover breather leaking oil - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old October 10th, 2008, 06:12 PM   #1
PHATS79
Member
 
PHATS79's Avatar
 
Join Date: 07-09-08
Location: Howard City, MI
Posts: 66
iTrader: (0)
Mentioned: 0 Post(s)
Default valve cover breather leaking oil

I hav a stupid problem thats more annoying than a problem. got a big block chevy and my valve cover breathers both leak oil out of them, they also have a little smoke come out of them when the motor gets up to temp. Is this an issue with my valves, or would new breathers fix the problem???
PHATS79 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old October 10th, 2008, 07:31 PM   #2
Yetti
Buy a Fiat! Save the UAW!
 
Yetti's Avatar
 
Join Date: 11-05-05
Location: 20 minutes south of Hell...
Posts: 14,385
iTrader: (10)
Mentioned: 2 Post(s)
Default

sounds like you eliminated your PCV valve? if so put one back in the system. it creates just enough vacuum to keep the oil in. secondly if your valve cover vents are puking oil then your oil return holes at the back of the heads maybe plugged? I have seen crap piled in the holes or head gasket material blocking them.
__________________
Yetti
Yetti is offline   Reply With Quote
Old October 10th, 2008, 09:17 PM   #3
s.hembree
Senior Member
 
s.hembree's Avatar
 
Join Date: 03-16-07
Location: Grand Rapids, MI
Posts: 1,409
iTrader: (5)
Mentioned: 0 Post(s)
Default

Do you have baffles in the covers or in the breathers?
s.hembree is online now   Reply With Quote
Old October 10th, 2008, 10:41 PM   #4
PHATS79
Member
 
PHATS79's Avatar
 
Join Date: 07-09-08
Location: Howard City, MI
Posts: 66
iTrader: (0)
Mentioned: 0 Post(s)
Default

there are baffles in the breathers i believe
PHATS79 is offline   Reply With Quote
Old October 10th, 2008, 10:44 PM   #5
PHATS79
Member
 
PHATS79's Avatar
 
Join Date: 07-09-08
Location: Howard City, MI
Posts: 66
iTrader: (0)
Mentioned: 0 Post(s)
Default

i will take the covers off and check the holes tomorrow, i doubt they are blocked though, the heads have maybe 10 hrs on them, just had the valves re-adjusted
PHATS79 is offline   Reply With Quote
Old October 13th, 2008, 04:13 AM   #6
2kids=nojeepmoney
Senior Member
 
Join Date: 01-13-08
Location: kALAMAZOO, mI
Posts: 983
iTrader: (18)
Mentioned: 0 Post(s)
Default

see the first reply. doesn't sound like you have a PCV installed.
2kids=nojeepmoney is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:51 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.10953 seconds with 38 queries