7.3L ford charging issues - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old September 5th, 2008, 11:20 PM   #1
lil monster
BUILT NOT BOUGHT
 
lil monster's Avatar
 
Join Date: 07-29-07
Location: grand rapids mi
Posts: 277
iTrader: (1)
Mentioned: 0 Post(s)
Send a message via Yahoo to lil monster
Default 7.3L ford charging issues

I have just replaced my regulator, harness, had the alt checked, checked the fuses and still no charge. I'm stumped. Any ideas?? ***UPDATE*** I found out that if I removed the regulator from the inner fender, I get a charge, but its 18volts. If I ground the regulator, I'm back to no charge.

Last edited by lil monster; September 7th, 2008 at 04:26 PM.
lil monster is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old September 7th, 2008, 07:42 PM   #2
lil monster
BUILT NOT BOUGHT
 
lil monster's Avatar
 
Join Date: 07-29-07
Location: grand rapids mi
Posts: 277
iTrader: (1)
Mentioned: 0 Post(s)
Send a message via Yahoo to lil monster
Default

Ttt
lil monster is offline   Reply With Quote
Old September 9th, 2008, 06:31 PM   #3
lil monster
BUILT NOT BOUGHT
 
lil monster's Avatar
 
Join Date: 07-29-07
Location: grand rapids mi
Posts: 277
iTrader: (1)
Mentioned: 0 Post(s)
Send a message via Yahoo to lil monster
Default

All wires have been replaced, and it charges, but the light is still on.
lil monster is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:14 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.06792 seconds with 29 queries