looking at a 89 ranger what do i look for? - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old August 25th, 2008, 11:12 AM   #1
skife
Senior Member
 
skife's Avatar
 
Join Date: 02-12-07
Location: cedar springs mi
Posts: 5,113
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to skife Send a message via MSN to skife
Default looking at a 89 ranger what do i look for?

clutch, brakes, alternator and fuelpump have all been replaced.

is there anything specific that goes wrong with these that i should look for?
skife is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old August 25th, 2008, 12:54 PM   #2
Bronco351
Powered by Ford
 
Bronco351's Avatar
 
Join Date: 09-26-07
Location: Garden City, MI; Pensacola, FL
Posts: 2,014
iTrader: (8)
Mentioned: 0 Post(s)
Send a message via Yahoo to Bronco351
Default

2.9L or the 4 cylinder?
if its a 2.9 w/ high miles, check the valve cover gaskets for leakage, ive heard that happens alot.
Bronco351 is offline   Reply With Quote
Old August 25th, 2008, 01:28 PM   #3
88mudder
In the band!
 
Join Date: 03-30-06
Location: waterford michigan
Posts: 3,678
iTrader: (29)
Mentioned: 0 Post(s)
Send a message via AIM to 88mudder Send a message via Skype™ to 88mudder
Default

check the body mounts make sure they arent rusting through..
check the floors for rust
if its the Automatic trans id say stop right there....the a4ld's are shit
88mudder is offline   Reply With Quote
Old August 25th, 2008, 02:29 PM   #4
skife
Senior Member
 
skife's Avatar
 
Join Date: 02-12-07
Location: cedar springs mi
Posts: 5,113
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to skife Send a message via MSN to skife
Default

5 speed 2.9 v6

4wd extended cab short box.

150000 miles
skife is offline   Reply With Quote
Old August 25th, 2008, 02:31 PM   #5
88mudder
In the band!
 
Join Date: 03-30-06
Location: waterford michigan
Posts: 3,678
iTrader: (29)
Mentioned: 0 Post(s)
Send a message via AIM to 88mudder Send a message via Skype™ to 88mudder
Default

if the engine dont have the lifter tick then go for it!
88mudder is offline   Reply With Quote
Old August 25th, 2008, 03:16 PM   #6
Bronco Ollie
Captain Jack Sparrow
 
Bronco Ollie's Avatar
 
Join Date: 11-03-06
Location: Windsor
Posts: 2,946
iTrader: (2)
Mentioned: 0 Post(s)
Default

look at the back hatch area lift up the carpet at the back make sure its solid look at the rad support and if those are good i would say buy it
Bronco Ollie is offline   Reply With Quote
Old August 25th, 2008, 07:08 PM   #7
fsumotorhead
N8KVB
 
fsumotorhead's Avatar
 
Join Date: 10-24-06
Location: Flat Rock, MI
Posts: 4,185
iTrader: (34)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by 88mudder View Post
check the body mounts make sure they arent rusting through..
check the floors for rust
if its the Automatic trans id say stop right there....the a4ld's are shit
definatly check the cab mounts for rust

in addition check the shackles for rust as well


can't remember which 5sp those had, but if it's the mazda, check the fluid as the seals on drop are prone to leaking and causing failures
fsumotorhead is offline   Reply With Quote
Old August 25th, 2008, 08:53 PM   #8
Bronco Ollie
Captain Jack Sparrow
 
Bronco Ollie's Avatar
 
Join Date: 11-03-06
Location: Windsor
Posts: 2,946
iTrader: (2)
Mentioned: 0 Post(s)
Default

the tranny will prolly be a fm-146
Bronco Ollie is offline   Reply With Quote
Old August 26th, 2008, 03:13 PM   #9
skife
Senior Member
 
skife's Avatar
 
Join Date: 02-12-07
Location: cedar springs mi
Posts: 5,113
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to skife Send a message via MSN to skife
Default

i drove by it today and decided that its a little bit to rusty for me.

there is a peice probably 2"x4" rusted out from the fender.
skife is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:15 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.97511 seconds with 47 queries