Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old August 10th, 2008, 10:18 PM   #1
offroad86b2
Senior Member
 
offroad86b2's Avatar
 
Join Date: 11-29-05
Location: Mount Clemens,MI.
Posts: 244
iTrader: (1)
Mentioned: 0 Post(s)
Send a message via AIM to offroad86b2
Default 1995 C6 trans problems

A friend of mine bought two 1995 ford E250 4x2 vans one has a bad engine the other has a bad trans.So we took the two and made one.the problem we are having is the trans its a C6 now when its in park it seems to be in drive too,when its in reverse it trys to go but seems like its in drive still...neutral is drive and drive is drive.you go down the road it shifts great through the gears.It just seems like its always stuck in drive..
I never messed with the internal linkage or know much about auto tranys,so if anyone has any ideas i would appreciate.
Thanks
offroad86b2 is offline   Reply With Quote
Old August 11th, 2008, 07:33 AM   #2
KILLER"B"468
Yankabilly
 
KILLER"B"468's Avatar
 
Join Date: 11-06-05
Location: Hendersonville Tn.
Posts: 7,945
iTrader: (19)
Mentioned: 0 Post(s)
Default

pull the pan and make sure the manual linkage is hooked to the manual valve.
__________________
being on the eastern edge of the central time zone sucks...it gets dark WAY to early.

Quote:
Originally Posted by jeepbrattt View Post
An occasional jello or vasoline wrestling match isn't out of the question either.
KILLER"B"468 is offline   Reply With Quote
Old August 13th, 2008, 06:42 AM   #3
offroad86b2
Senior Member
 
offroad86b2's Avatar
 
Join Date: 11-29-05
Location: Mount Clemens,MI.
Posts: 244
iTrader: (1)
Mentioned: 0 Post(s)
Send a message via AIM to offroad86b2
Default

i pulled it and its all hooked up so,i would have to say maybe a sticky valve in the valve body!! i dont know,the trans did sit for few years.
offroad86b2 is offline   Reply With Quote
Old August 13th, 2008, 10:16 AM   #4
Tranny Tom
Switcheroo
 
Tranny Tom's Avatar
 
Join Date: 10-13-06
Location: Southfield
Posts: 3,802
iTrader: (55)
Mentioned: 6 Post(s)
Default

Sounds like the forward clutches are smoked and locked on.... Just a possibility.
Tranny Tom is online now   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:13 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.06893 seconds with 18 queries