Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Suzuki Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old December 18th, 2013, 11:32 AM   #1
87mopar
Web Wheeler :(
 
87mopar's Avatar
 
Join Date: 10-08-08
Location: Lansing
Posts: 1,656
iTrader: (10)
1994 sidekick No start :(

I have searched around a bit and I'm leaning towards a bad ecm at the moment , but this is what I have. I just bought a 1994 sidekick for 300.00 dollars and it was running fine. This was until I went to pick it up. Then it wouldn't start. I sprayed starting fluid down the intake nothing at all. While just looking at the engine with the key on I heard a click and they could hear fuel moving to the injectors. It started and ran fine all the way home about 19 miles.

I started it up this morning decided I'd drive it to work and it died on the highway. Didn't sputter or anything just done. When I turn the key on I get no cel just the battery light and oil pressure light. I can't find a shrader valve so I can't check for fuel pressure. I think I can hear the FP in the tank. When I tow it home I'm going to check behind the tail light and see what that looks like (it was really slushy nasty this morning). I kinda like this car and want to get it back up and running. The No CEL light upon key being rotated is what is making me thing the ecm is bad
__________________
"Insert Comedic and or ego boosting quote questioning another members sexual orientation here"
http://www.greatlakes4x4.com/imageho...60bd7ea6d9.gif
87mopar is offline   Reply With Quote
Old December 18th, 2013, 12:48 PM   #2
87mopar
Web Wheeler :(
 
87mopar's Avatar
 
Join Date: 10-08-08
Location: Lansing
Posts: 1,656
iTrader: (10)
On another note I got it started and home, After cycling it for a few minutes I saw the cel light come on and I heard "stuff kick on" and It fired right up. Cel Light does not come on when it won't start.
__________________
"Insert Comedic and or ego boosting quote questioning another members sexual orientation here"
http://www.greatlakes4x4.com/imageho...60bd7ea6d9.gif
87mopar is offline   Reply With Quote
Old December 18th, 2013, 01:44 PM   #3
montecarlo33
Fuckin A
 
montecarlo33's Avatar
 
Join Date: 08-23-07
Location: Otsego County 49735
Posts: 4,049
iTrader: (16)
I would check fuel pressure first. Just because the pump is working, doesn't not mean it is kicking out enough PSI. A few key cycles tho it may have enough to start then.
montecarlo33 is online now   Reply With Quote
Old December 18th, 2013, 02:42 PM   #4
koochman450r
Stranger Danger
 
koochman450r's Avatar
 
Join Date: 03-13-08
Location: New Boston MI
Posts: 2,247
iTrader: (24)
Start with the basics. Check every wire connection you can. At battery, fuse panel, at ecm, anything else that a loose connection or corrosion could cause an intermittent problem. When it does mess up check to see if the ecm is getting power and all that.
__________________
MY BUILD
http://www.greatlakes4x4.com/showthread.php?t=255953
Quote:
Originally Posted by clarkstoncracker View Post
you won this battle.
koochman450r is offline   Reply With Quote
Old December 18th, 2013, 06:52 PM   #5
87mopar
Web Wheeler :(
 
87mopar's Avatar
 
Join Date: 10-08-08
Location: Lansing
Posts: 1,656
iTrader: (10)
Tomorrow I am going to go through everything I can when I get home from work. I want to get this thing up and running. I have it narrowed down to ecu issue or power to ecu issue leaning more toward the ecu failing because of the capacitors leaking. Looks to be super common. When its running it runs awesome. When its not well
__________________
"Insert Comedic and or ego boosting quote questioning another members sexual orientation here"
http://www.greatlakes4x4.com/imageho...60bd7ea6d9.gif
87mopar is offline   Reply With Quote
Old December 18th, 2013, 07:21 PM   #6
87mopar
Web Wheeler :(
 
87mopar's Avatar
 
Join Date: 10-08-08
Location: Lansing
Posts: 1,656
iTrader: (10)
I ordered a remaned ecu off ebay. To my knowledge it looks to be set up so I can plug it in. A 94 shouldn't need to be programmed right? I'm not new to cars but I'm new to suzuki/mitsubushi/sorta geo or what ever the hell this is.
__________________
"Insert Comedic and or ego boosting quote questioning another members sexual orientation here"
http://www.greatlakes4x4.com/imageho...60bd7ea6d9.gif
87mopar is offline   Reply With Quote
Old December 18th, 2013, 07:27 PM   #7
firehawk
Live Action!
 
firehawk's Avatar
 
Join Date: 10-02-07
Location: Clawson, Michigan
Posts: 12,024
iTrader: (41)
Quote:
Originally Posted by 87mopar View Post
I ordered a remaned ecu off ebay. To my knowledge it looks to be set up so I can plug it in. A 94 shouldn't need to be programmed right? I'm not new to cars but I'm new to suzuki/mitsubushi/sorta geo or what ever the hell this is.
Should plug in and work fine.
firehawk is offline   Reply With Quote
Old March 23rd, 2014, 07:17 AM   #8
Freebird01
Member
 
Join Date: 01-18-13
Location: Fort Wayne,IN
Posts: 90
iTrader: (0)
yep super common in all suzuki base vehicles (samurai,sidekick,tracker) the caps on the pc board in the ECU leak and eat the traces on the board. then can be repaired if your good with soldering. there was a guy over on zuwharrie.com that rebuilds them.

they fail in different ways. sometimes it stops the injector from firing...sometimes it stops it from having spark.

there should be a relay next to the ECM for the fuel pump and one for the ECM. sometimes they go bad too.

Grounds in any suzuki based vehicle are your mortal enemy!

Usually if the plug behind the drivers tail light is corroded the fuel pump wont run but thats about it
Freebird01 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Suzuki Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 09:58 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.09415 seconds with 28 queries