97 f150 idiot lights - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old October 26th, 2007, 10:30 AM   #1
nate4d
Gnarley Davidson
 
nate4d's Avatar
 
Join Date: 07-09-06
Location: Westland/Hale
Posts: 3,520
iTrader: (13)
Mentioned: 0 Post(s)
Send a message via AIM to nate4d
Default 97 f150 idiot lights

ABS ad E-brake light come on after it has been running for a while. anyone know why that might be? it doesnt effect the drive at all just annoying. its a 97 f150 with 4x4 and an automatic. if that makes a difference
nate4d is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old October 26th, 2007, 11:09 AM   #2
liv2mx
i like jungle gym's.
 
liv2mx's Avatar
 
Join Date: 11-10-05
Location: silver lake and up in the air building america
Posts: 11,175
iTrader: (4)
Mentioned: 4 Post(s)
Default

brakes are bad. maybe rear is shot. drum brakes on that. need any parts let me know i have a whole 97 f150 for parts.
liv2mx is offline   Reply With Quote
Old October 26th, 2007, 01:23 PM   #3
Bones
skillicous
 
Bones's Avatar
 
Join Date: 11-06-05
Location: Dearborn Heights, MI
Posts: 11,441
iTrader: (37)
Mentioned: 1 Post(s)
Send a message via AIM to Bones
Default

wheel speed sensers


go get the codes pulled
__________________
Inviscid Motorsports

Special Thanks and Recommendations to;
Motorcity Machines
Ironman Offroad
Branik Motorsports
Maxxis Tires

Raceline Wheels
PAC Racing Springs
Joint Clutch and Gear
Bones is online now   Reply With Quote
Old October 29th, 2007, 11:03 AM   #4
Lothos
KD8GKB
 
Lothos's Avatar
 
Join Date: 11-17-05
Location: .5 past lightspeed
Posts: 6,506
iTrader: (3)
Mentioned: 0 Post(s)
Send a message via ICQ to Lothos Send a message via AIM to Lothos Send a message via Yahoo to Lothos
Default

sensor on top of the rear diff. I think it was $40 when i did mine. The only other sensor is under the driver door somewhere.

That said though, I think you may have a dragging e-brake is all. The 97/98 MY's didn't implement wheel speed sensors, but rather a central axle speed slip sensor. It's also only Rear abs and not all wheel abs.
Lothos is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:50 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.09143 seconds with 33 queries