Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old October 6th, 2007, 04:59 PM   #1
88mudder
In the band!
 
Join Date: 03-30-06
Location: waterford michigan
Posts: 3,678
iTrader: (29)
Mentioned: 0 Post(s)
Send a message via AIM to 88mudder Send a message via Skype™ to 88mudder
Default stalls out in gear

I have an Edelbrock 4bbl on a 289 motor. It doesnt wanna idle when in gear. Ive ran a 2bbl on it and it still stalls out when i put it in gear. It idles in park and neutral. The trans is a c4 with a higher stahl converter. I tried turning up the idle up to 1400rpm but it still isnt right. Does anyone have any ideas here?
88mudder is offline   Reply With Quote
Old October 6th, 2007, 05:16 PM   #2
gofastbobby
The guy Dale doesn't know
 
gofastbobby's Avatar
 
Join Date: 03-10-07
Location: kalamazoo, mi
Posts: 4,171
iTrader: (1)
Mentioned: 0 Post(s)
Default

torque converter?
gofastbobby is offline   Reply With Quote
Old October 6th, 2007, 05:28 PM   #3
frdtrckmnrich
FORD The Best Never Rest
 
frdtrckmnrich's Avatar
 
Join Date: 04-07-06
Location: Fruitport MI
Posts: 3,064
iTrader: (46)
Mentioned: 2 Post(s)
Default

Quote:
Originally Posted by gofastbobby View Post
torque converter?
I agree, It sounds as if the torque converter is going bad.
frdtrckmnrich is online now   Reply With Quote
Old October 6th, 2007, 05:44 PM   #4
Bones
skillicous
 
Bones's Avatar
 
Join Date: 11-06-05
Location: Dearborn Heights, MI
Posts: 11,417
iTrader: (37)
Mentioned: 1 Post(s)
Send a message via AIM to Bones
Default

same in reverse as in drive?
__________________
Inviscid Motorsports

Special Thanks and Recommendations to;
Motorcity Machines
Ironman Offroad
Branik Motorsports
Maxxis Tires

Raceline Wheels
PAC Racing Springs
Joint Clutch and Gear
Bones is offline   Reply With Quote
Old October 6th, 2007, 08:34 PM   #5
88mudder
In the band!
 
Join Date: 03-30-06
Location: waterford michigan
Posts: 3,678
iTrader: (29)
Mentioned: 0 Post(s)
Send a message via AIM to 88mudder Send a message via Skype™ to 88mudder
Default

Quote:
Originally Posted by Bones View Post
same in reverse as in drive?
yeah both reverse and drive
88mudder is offline   Reply With Quote
Old October 6th, 2007, 08:41 PM   #6
88mudder
In the band!
 
Join Date: 03-30-06
Location: waterford michigan
Posts: 3,678
iTrader: (29)
Mentioned: 0 Post(s)
Send a message via AIM to 88mudder Send a message via Skype™ to 88mudder
Default

it doesnt go into reverse very well and in all the drive gears it seems to go into gear hard. So u guys think its a bad TC?
88mudder is offline   Reply With Quote
Old October 6th, 2007, 10:31 PM   #7
88mudder
In the band!
 
Join Date: 03-30-06
Location: waterford michigan
Posts: 3,678
iTrader: (29)
Mentioned: 0 Post(s)
Send a message via AIM to 88mudder Send a message via Skype™ to 88mudder
Default

i still gotta make sure i dont have a vac leak
88mudder is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 11:02 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.10705 seconds with 26 queries