Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old September 27th, 2007, 12:56 AM   #1
Leanz
Full taste of tender
 
Leanz's Avatar
 
Join Date: 11-04-05
Location: Oakland County, MI
Posts: 5,261
iTrader: (11)
Mentioned: 1 Post(s)
Default Mustang idle problem/throwing codes/fuel smell

00 v6 auto I have been having the code p0442 (small leak in evap system) go off lately. It seems to happen when Im at about 1/2 talk or less, then reset computer and refill tank, and it doesnt go on again untill about 1/2 tank or less... I just got a new gas cap, hoping to solve the computer problem. Well I havnt gotten down to 1/2 tank or less yet since the new cap so im not sure if ive solved the problem. I have noticed today at a stop sign my idle fell to about 400rpm then went up to 1000rpm then slowly went back down to 700rpm, its normal idle. After that episode it just ran like normal, untill i got home into my driveway and as i put it in park... maybe 30 seconds of just messing with crap in my car before i shut it off it did the same thing agian. I also noticed when i got out of the car, a raw fuel smell.... I popped the hood and sniffed around but i think it evaporated. ANY ideas?

Ive read around about cleaning my IAC or replacing my TPS but honestly do my seperate problems sound like they could be linked? maybe a vaccuum leak? Im not sure
Leanz is offline   Reply With Quote
Old September 27th, 2007, 01:24 AM   #2
Captain Ledd
Ranger Addiction?
 
Captain Ledd's Avatar
 
Join Date: 11-06-05
Location: Davisburg
Posts: 2,065
iTrader: (31)
Mentioned: 0 Post(s)
Default

My friend had a Sonoma that had some bad injectors in it. I do believe it idled weird and did stink of gas at times. As for the other sutff...
Captain Ledd is offline   Reply With Quote
Old September 27th, 2007, 10:54 AM   #3
Jeeperz Creeperz
Senior Member
 
Jeeperz Creeperz's Avatar
 
Join Date: 11-08-05
Location: Wyandotte, MI
Posts: 3,116
iTrader: (13)
Mentioned: 1 Post(s)
Send a message via ICQ to Jeeperz Creeperz Send a message via AIM to Jeeperz Creeperz Send a message via MSN to Jeeperz Creeperz Send a message via Yahoo to Jeeperz Creeperz
Default

Quote:
Originally Posted by Leanz View Post
00 v6 auto I have been having the code p0442 (small leak in evap system) go off lately.
You need to check the fuel lines/hoses for a leak. There is a "smoke machine" that is used to test the evap system for leaks, but it's gonna cost you to have them do that.
Jeeperz Creeperz is offline   Reply With Quote
Old September 27th, 2007, 11:03 AM   #4
Flexin' XJ
Senior Member
 
Flexin' XJ's Avatar
 
Join Date: 02-04-07
Location: Holt, MI
Posts: 4,459
iTrader: (19)
Mentioned: 0 Post(s)
Default

Sounds like maybe a EVAP Vent Valve. GM has issues with them. Usually they get plugged up with dirt and mud and cannot close all the way. This causes the small leak.

EVAP leaks are determined by monitoring the pressure in the gas tank by the pressure sensor that is located on the gas tank. If the pressure loss is above a certain amount, then you will get the small leak code, if it is a larger loss, then you will get a large leak.
Flexin' XJ is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 01:23 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.09241 seconds with 20 queries