Ford Truck Question - Page 2 - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier All Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old June 2nd, 2007, 09:06 PM   #21
bj house
Senior Member
 
bj house's Avatar
 
Join Date: 06-02-06
Location: Auburn Hills, MI
Posts: 5,289
iTrader: (4)
Mentioned: 0 Post(s)
Default

yeah I got a good deal for $50 two years ago
bj house is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old June 2nd, 2007, 09:22 PM   #22
Freak
Wheelin the HD
 
Freak's Avatar
 
Join Date: 01-27-07
Location: Portland, TX
Posts: 7,227
iTrader: (14)
Mentioned: 0 Post(s)
Send a message via MSN to Freak Send a message via Yahoo to Freak
Default

well, the biggest problem on it is that damn blue oval, aside from that everything else will fail, uncle has one with a blown transfer case and he just rebuilt the trans, thats a 99 w/ 7.3 and only around 90k on it, thats a farm truck, problems he had when he first got it was the ABS controller liked to somehow engage the breaks and CPS went out twice.

Friend has a 02 E350 with the 7.3 that he has done nothing but baby and he cant keep an alternator it in (goes about every 3 months) and the trans is about to go.

Last edited by Freak; June 2nd, 2007 at 09:42 PM.
Freak is offline   Reply With Quote
Old June 2nd, 2007, 09:33 PM   #23
bigcountrysg
Countryboy
 
bigcountrysg's Avatar
 
Join Date: 05-07-07
Location: Willis Michigan
Posts: 1,599
iTrader: (3)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by Freak View Post
well, the biggest problem on it is that damn blue oval, aside from that everything else will fail, uncle has one with a blown transfer case and he just rebuilt the trans, thats a 99 w/ 7.3 and only around 90k on it, thats a farm truck, problems he had when he first got it was the ABS controller liked to somehow engage the breaks and CPS went out twice.

Friend has a 04 E350 with the 7.3 that he has done nothing but baby and he cant keep an alternator it in (goes about every 3 months) and the trans is about to go.
That is freakin funny an 04 E350 with a 7.3L hmmm the last freakin year for the 7.3L was in 02, the 7.3L was used in the early 03's but come lat 03 it was the 6.0L

Maybe you better ask your friend what year there E350 is again and what size motor is in it.
bigcountrysg is offline   Reply With Quote
Old June 2nd, 2007, 09:43 PM   #24
Freak
Wheelin the HD
 
Freak's Avatar
 
Join Date: 01-27-07
Location: Portland, TX
Posts: 7,227
iTrader: (14)
Mentioned: 0 Post(s)
Send a message via MSN to Freak Send a message via Yahoo to Freak
Default

Quote:
Originally Posted by bigcountrysg View Post
That is freakin funny an 04 E350 with a 7.3L hmmm the last freakin year for the 7.3L was in 02, the 7.3L was used in the early 03's but come lat 03 it was the 6.0L

Maybe you better ask your friend what year there E350 is again and what size motor is in it.


Fixed, I knew it was after 01 wasn't sure, just know its had 3 alternators, 3 battery's and 1 computer and now the trans is slipping and he has had it under 2 years.
Freak is offline   Reply With Quote
Old June 4th, 2007, 09:31 AM   #25
alboy79
Wheres your loyaltys lie?
 
alboy79's Avatar
 
Join Date: 02-09-06
Location: Conklin, Michigan or 49403 for shipping
Posts: 11,461
iTrader: (33)
Mentioned: 2 Post(s)
Default

Ive got 169,ooo on my 97 and my buddy has 360,000 on his 95 and both run great. no problems with engine besides changeing a fuel filter.
__________________
CheapThrills Off-Road
Ill see you when I see you, Fullsize4life
It might be lonely at the top, but its a bitch at the bottom.
alboy79 is offline   Reply With Quote
Old June 4th, 2007, 09:34 AM   #26
bigcountrysg
Countryboy
 
bigcountrysg's Avatar
 
Join Date: 05-07-07
Location: Willis Michigan
Posts: 1,599
iTrader: (3)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by Freak View Post
Fixed, I knew it was after 01 wasn't sure, just know its had 3 alternators, 3 battery's and 1 computer and now the trans is slipping and he has had it under 2 years.
I have put 3 alternators and 3 sets of batteries in my truck as well as 3 trannies. But then again I got 145,000 on my truck.
bigcountrysg is offline   Reply With Quote
Old June 4th, 2007, 09:39 AM   #27
ScOoTeR
hoo dat. wat.
 
ScOoTeR's Avatar
 
Join Date: 11-09-05
Location: Howell
Posts: 21,467
iTrader: (35)
Mentioned: 6 Post(s)
Default

145k on my 96 and just replaced the OEM batteries last year; ten years ain't bad. No alternator problems, but I did replace my dual mass flywheel for a single mass unit and a SouthBend clutch.

Replaced the glowplugs at 105K

U-joints and center bearings at 143k

Getting ready to do the TREs and ball joints soon. Not bad for a "POS" AMerican truck!
__________________
@clarkstoncracker
ScOoTeR is offline   Reply With Quote
Old June 4th, 2007, 10:09 AM   #28
Bones
skillicous
 
Bones's Avatar
 
Join Date: 11-06-05
Location: Dearborn Heights, MI
Posts: 11,433
iTrader: (37)
Mentioned: 1 Post(s)
Send a message via AIM to Bones
Default

PM me the VIN for the Ford you want to buy.... I'll help with what it is and it's history.

my 97 F250 4x4 was great. Sold it with 320K miles on it, It has the first trans rebuilt around 170K and was due for another. All original motor except GPs, alt, belt, etc.
__________________
Inviscid Motorsports

Special Thanks and Recommendations to;
Motorcity Machines
Ironman Offroad
Branik Motorsports
Maxxis Tires

Raceline Wheels
PAC Racing Springs
Joint Clutch and Gear
Bones is online now   Reply With Quote
Old June 4th, 2007, 10:59 AM   #29
bigcountrysg
Countryboy
 
bigcountrysg's Avatar
 
Join Date: 05-07-07
Location: Willis Michigan
Posts: 1,599
iTrader: (3)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by Bones View Post
PM me the VIN for the Ford you want to buy.... I'll help with what it is and it's history.

my 97 F250 4x4 was great. Sold it with 320K miles on it, It has the first trans rebuilt around 170K and was due for another. All original motor except GPs, alt, belt, etc.
So you have the capability of doing an Oasis report huh.
bigcountrysg is offline   Reply With Quote
Old June 4th, 2007, 11:08 AM   #30
Bones
skillicous
 
Bones's Avatar
 
Join Date: 11-06-05
Location: Dearborn Heights, MI
Posts: 11,433
iTrader: (37)
Mentioned: 1 Post(s)
Send a message via AIM to Bones
Default

Quote:
Originally Posted by bigcountrysg View Post
So you have the capability of doing an Oasis report huh.
yeah, mainly only look at the AWS reports though
__________________
Inviscid Motorsports

Special Thanks and Recommendations to;
Motorcity Machines
Ironman Offroad
Branik Motorsports
Maxxis Tires

Raceline Wheels
PAC Racing Springs
Joint Clutch and Gear
Bones is online now   Reply With Quote
Old June 5th, 2007, 09:26 PM   #31
Symmes
Senior Member
 
Join Date: 11-28-05
Location: Grand Rapids
Posts: 429
iTrader: (-1)
Mentioned: 0 Post(s)
Default

My uncle has 400,000 thousand on his and its still running good.
Symmes is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:27 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.15522 seconds with 54 queries