Need help- Pontiac G6 rough idle - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old June 3rd, 2014, 05:33 PM   #1
Jeep Thrills
Lumbermonkey/pedalpusher
 
Jeep Thrills's Avatar
 
Join Date: 02-14-08
Location: Flushing,Mi
Posts: 716
iTrader: (6)
Mentioned: 0 Post(s)
Default Need help- Pontiac G6 rough idle

2.4L 145CI L4 FI. 106,000 miles. Just started running rough today. Rough idle and stalling. Converter has been replaced once over a year ago. Do they have an inline replaceable fuel filter or is it in the tank?
Jeep Thrills is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old June 3rd, 2014, 05:38 PM   #2
Toyfish
Senior Member
 
Toyfish's Avatar
 
Join Date: 02-05-10
Location: lapeer, MI
Posts: 2,020
iTrader: (29)
Mentioned: 5 Post(s)
Default

there is a inline filter on those have the spark plugs ever been done? is there a check engine light on?
Toyfish is offline   Reply With Quote
Old June 3rd, 2014, 05:40 PM   #3
Jeep Thrills
Lumbermonkey/pedalpusher
 
Jeep Thrills's Avatar
 
Join Date: 02-14-08
Location: Flushing,Mi
Posts: 716
iTrader: (6)
Mentioned: 0 Post(s)
Default

CEL has been on for a while. It's the wife's car, so no idea how long. Plugs have never been done as far as I know.
Jeep Thrills is offline   Reply With Quote
Old June 3rd, 2014, 06:15 PM   #4
Toyfish
Senior Member
 
Toyfish's Avatar
 
Join Date: 02-05-10
Location: lapeer, MI
Posts: 2,020
iTrader: (29)
Mentioned: 5 Post(s)
Default

change the plugs first only use ac delco platnim plugs
Toyfish is offline   Reply With Quote
Old June 3rd, 2014, 06:30 PM   #5
Jeep Thrills
Lumbermonkey/pedalpusher
 
Jeep Thrills's Avatar
 
Join Date: 02-14-08
Location: Flushing,Mi
Posts: 716
iTrader: (6)
Mentioned: 0 Post(s)
Default

I'm guessing the electrodes should not be pointy. Sending the wife to get some right now. I guess I get to feed the skeeters some more.
Jeep Thrills is offline   Reply With Quote
Old June 3rd, 2014, 06:32 PM   #6
Toyfish
Senior Member
 
Toyfish's Avatar
 
Join Date: 02-05-10
Location: lapeer, MI
Posts: 2,020
iTrader: (29)
Mentioned: 5 Post(s)
Default

they should have a small point on the tip they should be changed every 100k and its a easy place to start if its running shitty
Toyfish is offline   Reply With Quote
Old June 3rd, 2014, 08:03 PM   #7
fordbronco
ate yo' baby
 
fordbronco's Avatar
 
Join Date: 02-22-11
Location: Marlette/Flint
Posts: 4,718
iTrader: (2)
Mentioned: 5 Post(s)
Default

X2 especially since it's the ecotec. Should take you 2 minutes to put the plugs in.
fordbronco is offline   Reply With Quote
Old June 3rd, 2014, 08:13 PM   #8
Jeep Thrills
Lumbermonkey/pedalpusher
 
Jeep Thrills's Avatar
 
Join Date: 02-14-08
Location: Flushing,Mi
Posts: 716
iTrader: (6)
Mentioned: 0 Post(s)
Default

New plugs, same crap. The engine will rev if you pump the pedal to bring the rpms up, but when I let the rpms come down it stalls. I don't have a fuel pressure tester, but when I push the bleeder in after it stalls I just get a short burst of fuel, but it seems like there should be more. I might have to rent a pressure tester tomorrow.
Jeep Thrills is offline   Reply With Quote
Old June 3rd, 2014, 08:43 PM   #9
fordbronco
ate yo' baby
 
fordbronco's Avatar
 
Join Date: 02-22-11
Location: Marlette/Flint
Posts: 4,718
iTrader: (2)
Mentioned: 5 Post(s)
Default

While you're out there tomorrow, I'd check into the CEL and see what you have for codes.
fordbronco is offline   Reply With Quote
Old June 3rd, 2014, 08:53 PM   #10
Jeep Thrills
Lumbermonkey/pedalpusher
 
Jeep Thrills's Avatar
 
Join Date: 02-14-08
Location: Flushing,Mi
Posts: 716
iTrader: (6)
Mentioned: 0 Post(s)
Default

I'd have to get it scanned somewhere or borrow a scanner. I found a recall notice for a defective pump connection, hoping it'll be that easy.
Jeep Thrills is offline   Reply With Quote
Old June 4th, 2014, 08:20 AM   #11
Outdoors
Field Repairs
 
Outdoors's Avatar
 
Join Date: 02-08-06
Location: Stevensville
Posts: 164
iTrader: (0)
Mentioned: 1 Post(s)
Default

Check the line coming off the PCV valve. When the crack the create a problem close to what you are describing.
Outdoors is offline   Reply With Quote
Old June 4th, 2014, 08:23 AM   #12
lepp1892
WebWheeling1KeyAtaTime
 
lepp1892's Avatar
 
Join Date: 09-06-07
Location: Indianapolis, IN
Posts: 740
iTrader: (8)
Mentioned: 0 Post(s)
Default

Sounds like a TCC solenoid to me.
lepp1892 is online now   Reply With Quote
Old June 4th, 2014, 05:59 PM   #13
Jeep Thrills
Lumbermonkey/pedalpusher
 
Jeep Thrills's Avatar
 
Join Date: 02-14-08
Location: Flushing,Mi
Posts: 716
iTrader: (6)
Mentioned: 0 Post(s)
Default

Didn't get a tester, but I can get the engine to run off of carb cleaner, so I know it is fuel related.
Jeep Thrills is offline   Reply With Quote
Old June 5th, 2014, 07:55 AM   #14
Outdoors
Field Repairs
 
Outdoors's Avatar
 
Join Date: 02-08-06
Location: Stevensville
Posts: 164
iTrader: (0)
Mentioned: 1 Post(s)
Default

Looks like Toyfish then had the answer in the first seven words of suggestions. Good job Toyfish! You put this old man to shame.
Outdoors is offline   Reply With Quote
Old June 5th, 2014, 10:05 AM   #15
Toyfish
Senior Member
 
Toyfish's Avatar
 
Join Date: 02-05-10
Location: lapeer, MI
Posts: 2,020
iTrader: (29)
Mentioned: 5 Post(s)
Default

Quote:
Originally Posted by Outdoors View Post
Looks like Toyfish then had the answer in the first seven words of suggestions. Good job Toyfish! You put this old man to shame.
Trust me its not easy being this good lol

Sent from my DROID X2 using Tapatalk 2
Toyfish is offline   Reply With Quote
Old June 5th, 2014, 03:37 PM   #16
Jeep Thrills
Lumbermonkey/pedalpusher
 
Jeep Thrills's Avatar
 
Join Date: 02-14-08
Location: Flushing,Mi
Posts: 716
iTrader: (6)
Mentioned: 0 Post(s)
Default

fuel pressure regulator is
in the tank I'm guessing?
Jeep Thrills is offline   Reply With Quote
Old June 5th, 2014, 03:38 PM   #17
Jeep Thrills
Lumbermonkey/pedalpusher
 
Jeep Thrills's Avatar
 
Join Date: 02-14-08
Location: Flushing,Mi
Posts: 716
iTrader: (6)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by Jeep Thrills View Post
Didn't get a tester, but I can get the engine to run off of carb cleaner, so I know it is fuel related.
Picking up a fuel pump on the way home.
Jeep Thrills is offline   Reply With Quote
Old June 7th, 2014, 07:29 PM   #18
Jeep Thrills
Lumbermonkey/pedalpusher
 
Jeep Thrills's Avatar
 
Join Date: 02-14-08
Location: Flushing,Mi
Posts: 716
iTrader: (6)
Mentioned: 0 Post(s)
Default

Fixxered. Miller time.
Jeep Thrills is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:06 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.16694 seconds with 75 queries