Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old May 9th, 2014, 02:09 PM   #1
catmando
Senior Member
 
catmando's Avatar
 
Join Date: 06-18-08
Location: Owosso, Mi
Posts: 217
iTrader: (3)
Mentioned: 0 Post(s)
Default Chevy ZZ350

Well the purple junk is back together and it still dose the same thing. Had the heads milled and checked for cracks and all is good there. Still pushing to much coolant out the over flow. Any ideas anyone
catmando is offline   Reply With Quote
Old May 9th, 2014, 04:34 PM   #2
unclebeaner
can you hear the banjos?
 
unclebeaner's Avatar
 
Join Date: 04-04-06
Location: Flat Rock 48134
Posts: 8,902
iTrader: (70)
Mentioned: 0 Post(s)
Default

intake or block
__________________
Avid collector of useless things.
unclebeaner is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 10:37 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.05491 seconds with 16 queries