(Trans help)!!!2005 jeep grand Cherokee 5.7 - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old April 23rd, 2014, 07:37 AM   #1
Jesse128
128
 
Jesse128's Avatar
 
Join Date: 12-03-13
Location: Fenton michigan
Posts: 22
iTrader: (0)
Mentioned: 0 Post(s)
Default (Trans help)!!!2005 jeep grand Cherokee 5.7

I was driving on the eway today and it shifted down to 3rd gear and stayed in 3rd. I have been doing some reading already and people have said it's called safe mode? When it does that. This is the first time it has happened. I also read that the filters crack and let's it such air. Also read there are some speed sensors? or something like that on the trans that could go bad. The jeep has 97000 miles and I guess what I'm asking is if this is a common problem with jeep or if anyone knows what's wrong. When I get home I'm gonna plug it in and see what my scanner tells me
Jesse128 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old April 23rd, 2014, 07:48 AM   #2
Tranny Tom
Switcheroo
 
Tranny Tom's Avatar
 
Join Date: 10-13-06
Location: Southfield
Posts: 3,822
iTrader: (55)
Mentioned: 10 Post(s)
Default

Have it scanned for codes and report back with the code number and description.

When the trans gets put into limp mode it means the computer senses a problem, throws a code and puts into a safe mode.

People can list 15 things that "could" be your problem, but the easiest and fastest way is to have it scanned. It will give you a starting point and prevent you from just throwing parts at it guessing what is wrong with it.
Tranny Tom is online now   Reply With Quote
Old April 23rd, 2014, 11:23 AM   #3
Jesse128
128
 
Jesse128's Avatar
 
Join Date: 12-03-13
Location: Fenton michigan
Posts: 22
iTrader: (0)
Mentioned: 0 Post(s)
Default

Thank you. I have a OTC genisys I'm gonna plug it in when I get out of work. Thanks again I definitely don't want to just throw parts at it
Jesse128 is offline   Reply With Quote
Old April 23rd, 2014, 06:49 PM   #4
Jesse128
128
 
Jesse128's Avatar
 
Join Date: 12-03-13
Location: Fenton michigan
Posts: 22
iTrader: (0)
Mentioned: 0 Post(s)
Default

P0988 4C Pressure Switch Rationality
Jesse128 is offline   Reply With Quote
Old April 23rd, 2014, 06:57 PM   #5
Jesse128
128
 
Jesse128's Avatar
 
Join Date: 12-03-13
Location: Fenton michigan
Posts: 22
iTrader: (0)
Mentioned: 0 Post(s)
Default

The first code was from the trans computer and this one is from the engine P0700 transmission control system ( malfunction indicator lamp request)
Jesse128 is offline   Reply With Quote
Old April 23rd, 2014, 07:04 PM   #6
Jesse128
128
 
Jesse128's Avatar
 
Join Date: 12-03-13
Location: Fenton michigan
Posts: 22
iTrader: (0)
Mentioned: 0 Post(s)
Default

I'm looking at modulation pressure on my scanner and it says no data. KEO and KER
Jesse128 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:01 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.10535 seconds with 39 queries