Build my 727 trans - Page 2 - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old March 10th, 2014, 12:29 PM   #21
Strangler
Senior Member
 
Strangler's Avatar
 
Join Date: 12-12-05
Location: Howell
Posts: 4,064
iTrader: (52)
Mentioned: 2 Post(s)
Default

Put a Chevy in it.
Strangler is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old March 10th, 2014, 12:38 PM   #22
Wramblerguy
Senior Member
 
Wramblerguy's Avatar
 
Join Date: 04-02-11
Location: Schoolcraft 49087
Posts: 3,164
iTrader: (10)
Mentioned: 3 Post(s)
Default

Add a third pedal
My trans never overheats
__________________
3rd generation jeeper

99 gmc Sierra extended cab z71 dd
87 yj Laredo 4.2/999/231 ac & cruise bone stock (for now)
90s Wrambler efi 2.5, t5, sye231 ,d44s with 4.88s and detroits
Wramblerguy is offline   Reply With Quote
Old March 10th, 2014, 02:16 PM   #23
Plato2k5
In Da Faaaaaace!!!
 
Plato2k5's Avatar
 
Join Date: 12-25-05
Location: WMU Kzoo Mi / Livonia, MI
Posts: 5,431
iTrader: (17)
Mentioned: 0 Post(s)
Send a message via AIM to Plato2k5
Default

Lol no Scott.

I enjoy the auto to much. When I had a manual, I hated it. Never lasted
Plato2k5 is offline   Reply With Quote
Old March 10th, 2014, 04:09 PM   #24
v2win
Senior Member
 
v2win's Avatar
 
Join Date: 01-18-07
Location: Sterling Heights Mi
Posts: 360
iTrader: (13)
Mentioned: 0 Post(s)
Default

Do you have the kick down linkage installed and operating correctly or is it wired wide open? If its wired all the way open it will burn up bands.

Are you holding the trans in low gear when you are in hi range in the tcase? It needs to shift or it will overheat.
v2win is offline   Reply With Quote
Old March 11th, 2014, 11:05 AM   #25
Plato2k5
In Da Faaaaaace!!!
 
Plato2k5's Avatar
 
Join Date: 12-25-05
Location: WMU Kzoo Mi / Livonia, MI
Posts: 5,431
iTrader: (17)
Mentioned: 0 Post(s)
Send a message via AIM to Plato2k5
Default

Cable operates perfectly and moves freely throughout the total range of motion.

I pick the highest gear the rpm allows when off road.

I'm calling companies for a tc, tci recommended a 2400 stall they sell. Looking into edge now.

My cooler lines look like they could be opened up a lot. I'm sure running 1/2 line will free up some flow. The h-pipe runs rite behind the trans pan....while I wrapped it, I'm sure that isn't helping my issue.
Plato2k5 is offline   Reply With Quote
Old March 12th, 2014, 12:37 PM   #26
Plato2k5
In Da Faaaaaace!!!
 
Plato2k5's Avatar
 
Join Date: 12-25-05
Location: WMU Kzoo Mi / Livonia, MI
Posts: 5,431
iTrader: (17)
Mentioned: 0 Post(s)
Send a message via AIM to Plato2k5
Default

Well inspected all parts.....broken bellvile spring in 3 pieces, two front clutches to bare metal on the ends...the other have barley ant friction material left, crack on the input shaft.
Plato2k5 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:15 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.09732 seconds with 39 queries