Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old October 21st, 2013, 08:45 PM   #1
tj84
Member
 
tj84's Avatar
 
Join Date: 12-07-07
Location: indiana
Posts: 96
iTrader: (0)
Mentioned: 0 Post(s)
Default leaking front seal

I just bought a 1994 zj and the front seal on the transmission was leaking a lot of fluid out , I pulled it out and put a new seal in it and it is doing the same thing .only does it when I put it in gear. nothing looked cracked when I put the seal in. I am willing to pull it and rebuild it but I don't want to pull it again if it starts leaking again. any ideas what or where it is leaking?
thanks bill
tj84 is offline   Reply With Quote
Old October 25th, 2013, 06:06 PM   #2
skife
Senior Member
 
skife's Avatar
 
Join Date: 02-12-07
Location: cedar springs mi
Posts: 5,101
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to skife Send a message via MSN to skife
Default

Maybe pump bearing going out?
skife is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 10:44 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.05484 seconds with 16 queries